summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD28
2 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c15ab4ef8a35
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = duckdns
+ pkgdesc = Update your DuckDNS.org entries from your computer without setting up any cronjob. You just need to create config files for your domains.
+ pkgver = 1.0.0
+ pkgrel = 1
+ url = https://stroobants.io
+ arch = any
+ license = MIT
+ backup = etc/duckdns.d/default.cfg
+ source = https://stroobants.io/wp-content/uploads/2015/09/duckdns-1.0.0.tar.gz
+ md5sums = 78ea999eaa92e8b005464ca37544cf62
+
+pkgname = duckdns
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9314668e8a08
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Tom Stroobants <stroobantstom@gmail.com>
+pkgname=duckdns
+pkgver=1.0.0
+pkgrel=1
+pkgdesc="Update your DuckDNS.org entries from your computer without setting up any cronjob. You just need to create config files for your domains."
+arch=('any')
+url="https://stroobants.io"
+license=('MIT')
+backup=("etc/duckdns.d/default.cfg")
+
+source=("https://stroobants.io/wp-content/uploads/2015/09/${pkgname}-${pkgver}.tar.gz")
+md5sums=('78ea999eaa92e8b005464ca37544cf62')
+
+package() {
+ cd ${pkgname}
+
+ install -D duckdns.sh "${pkgdir}/usr/bin/${pkgname}"
+ install -D LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+
+ install -d "${pkgdir}/etc/duckdns.d/"
+
+ install -Dm644 default.cfg "${pkgdir}/etc/duckdns.d/default.cfg"
+
+ install -Dm644 duckdns.service "${pkgdir}/usr/lib/systemd/system/duckdns.service"
+ install -Dm644 duckdns.timer "${pkgdir}/usr/lib/systemd/system/duckdns.timer"
+
+
+}