summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD8
-rwxr-xr-xupdate.sh (renamed from bump.sh)8
3 files changed, 16 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d8732d87400a..07e5893c4eb8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,15 @@
pkgbase = duckstation-qt-bin
pkgdesc = Fast PlayStation 1 emulator for PC and Android
- pkgver = 0.1.r6515
+ pkgver = 0.1.r6720
pkgrel = 1
url = https://github.com/stenzek/duckstation
arch = x86_64
- license = GPL3
+ license = GPL-3.0-only
provides = duckstation-qt
provides = duckstation
- noextract = duckstation-qt-0.1.r6515.AppImage
+ noextract = duckstation-qt-0.1.r6720.AppImage
options = !strip
- source = duckstation-qt-0.1.r6515.AppImage::https://github.com/stenzek/duckstation/releases/download/latest/DuckStation-x64.AppImage
- sha256sums = 1a524b5c18d2489e7f3e2af85afcfd02b313335f19e1046b5147c93001ded4ce
+ source = duckstation-qt-0.1.r6720.AppImage::https://github.com/stenzek/duckstation/releases/download/latest/DuckStation-x64.AppImage
+ sha256sums = 559515eebfbe1344bd2d16e589d49694b0044ef75bf7affacd11d0f34ab849e9
pkgname = duckstation-qt-bin
diff --git a/PKGBUILD b/PKGBUILD
index 8e4582c8a759..509f1de28c9a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,17 +5,17 @@
pkgname=duckstation-qt-bin
_pkgname="${pkgname%-bin}"
_fullname=org.duckstation.DuckStation
-pkgver=0.1.r6515
+pkgver=0.1.r6720
pkgrel=1
pkgdesc="Fast PlayStation 1 emulator for PC and Android"
arch=('x86_64')
url='https://github.com/stenzek/duckstation'
-license=('GPL3')
+license=('GPL-3.0-only')
provides=("$_pkgname" 'duckstation')
options=('!strip')
noextract=("${_pkgname}-${pkgver}.AppImage")
source=("${_pkgname}-${pkgver}.AppImage::https://github.com/stenzek/duckstation/releases/download/latest/DuckStation-x64.AppImage")
-sha256sums=('1a524b5c18d2489e7f3e2af85afcfd02b313335f19e1046b5147c93001ded4ce')
+sha256sums=('559515eebfbe1344bd2d16e589d49694b0044ef75bf7affacd11d0f34ab849e9')
package() {
chmod 755 "$srcdir/${_pkgname}-${pkgver}.AppImage"
@@ -28,6 +28,6 @@ package() {
#!/bin/sh
cd /opt/$_pkgname && ./AppRun
EOF
- install -Dm755 ${_pkgname}.sh "$pkgdir/usr/bin/$_pkgname"
+ install -Dm755 "${_pkgname}.sh" "$pkgdir/usr/bin/$_pkgname"
find "$pkgdir/opt/$_pkgname" -type d -exec chmod 755 {} +
}
diff --git a/bump.sh b/update.sh
index 86f442e326e0..745722fc0237 100755
--- a/bump.sh
+++ b/update.sh
@@ -1,13 +1,19 @@
#!/bin/sh
set -o errexit
+
wget --no-clobber 'https://github.com/stenzek/duckstation/releases/download/latest/DuckStation-x64.AppImage'
+rm -rf ./squashfs-root
+
chmod u+x ./DuckStation-x64.AppImage
./DuckStation-x64.AppImage --appimage-extract
+
version="$(xq -r '.component.releases.release["@version"]' < squashfs-root/usr/share/metainfo/org.duckstation.DuckStation.metainfo.xml)"
version="${version%-*}"
revision="${version#0\.1-}"
-echo "$revision"
+echo "Revision: $revision"
sed -i "s/^pkgver=.*$/pkgver=0.1.r${revision}/" PKGBUILD
+
mv DuckStation-x64.AppImage "duckstation-qt-0.1.r${revision}.AppImage"
+
updpkgsums
makepkg --printsrcinfo > .SRCINFO