summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO28
-rw-r--r--CHANGELOG.md37
-rw-r--r--PKGBUILD88
-rw-r--r--dunedynasty.ChangeLog5
-rw-r--r--dunedynasty.desktop8
-rw-r--r--dunedynasty.install14
6 files changed, 112 insertions, 68 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 97ad277ba3c2..17bcd498db26 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,24 +1,24 @@
pkgbase = dunedynasty
- pkgdesc = Enhanced continuation of the classic real-time strategy game Dune II
- pkgver = 1.5.7
+ pkgdesc = Maintained fork of an enhanced continuation of the classic real-time strategy game Dune II
+ pkgver = 1.6.2
pkgrel = 1
- url = http://dunedynasty.sourceforge.net/
+ url = https://github.com/gameflorist/dunedynasty
install = dunedynasty.install
- changelog = dunedynasty.ChangeLog
+ changelog = CHANGELOG.md
arch = i686
arch = x86_64
- license = GPL2
+ license = GPL-2.0-only
makedepends = cmake
depends = allegro
- optdepends = fluidsynth: software synthesizer for midi music
- optdepends = soundfont-fluid: good soundfont for use with fluidsynth
- optdepends = timidity++: alternative midi sequencer
+ depends = alsa-lib
+ depends = enet
+ depends = libgl
+ optdepends = fluidsynth: MIDI music support alternative
+ optdepends = soundfont-fluid: soundfont for fluidsynth
+ optdepends = timidity++: MIDI music support alternative
optdepends = timidity-freepats: patch set for timidity++
- optdepends = libmad: for mp3 music support
- source = http://downloads.sourceforge.net/dunedynasty/dunedynasty-1.5.7.tar.gz
- source = dunedynasty.desktop
- sha256sums = a50e5a643db6835acb8cf7afd262b5eeba3fac01151ea51afcb1f5914d35a5c5
- sha256sums = 4bc37a890a354e274b152a03fffa61d2da1609131c848742e1e4bca537176493
+ optdepends = libmad: MP3 music support
+ source = dunedynasty-1.6.2.tar.gz::https://github.com/gameflorist/dunedynasty/archive/refs/tags/v1.6.2.tar.gz
+ sha256sums = 97ca7af2423279674e4ac290a1c7d6ae85ad8a58b56108c8acceae829086a40f
pkgname = dunedynasty
-
diff --git a/CHANGELOG.md b/CHANGELOG.md
new file mode 100644
index 000000000000..5b1db4e98457
--- /dev/null
+++ b/CHANGELOG.md
@@ -0,0 +1,37 @@
+# Changelog
+
+## [1.6.2-1] 2024-04-04
+
+Switch to an actively maintained
+[fork](https://github.com/gameflorist/dunedynasty) of the
+abandoned, [original project](https://dunedynasty.sourceforge.net).
+
+### Added
+
+- Add dependencies on `alsa-lib`, `enet`, and `libgl` (Gyroplast)
+- Add preference for GLVND over legacy OpenGL (Gyroplast)
+
+### Changed
+
+- Switch sources to actively maintained fork (Gyroplast)
+- Install upstream-provided .desktop file (Gyroplast)
+
+### Fixed
+
+- Suppress format-security error to compile with default makepkg cflags (Gyroplast)
+
+### Removed
+
+- Remove post-upgrade message (Gyroplast)
+
+## [1.5.7-1] 2014-01-12
+
+Package submitted.
+
+### Added
+
+- Add .desktop file (carstene1ns)
+
+[1.6.2-1]: https://github.com/gameflorist/dunedynasty/releases/tag/v1.6.2
+[1.5.7-1]: https://dunedynasty.sourceforge.net/changes.html#version-1.5.7-2013-08-18
+
diff --git a/PKGBUILD b/PKGBUILD
index c87c3a7399d7..733762355572 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,51 +1,75 @@
-# Maintainer: carstene1ns <arch carsten-teibes de> - http://git.io/ctPKG
+# Maintainer: Dennis Herbrich (Gyroplast) <dennis.herbrich@veloxis.de>
+# Contributor: carstene1ns <arch carsten-teibes de> - http://git.io/ctPKG
pkgname=dunedynasty
-pkgver=1.5.7
+pkgver=1.6.2
pkgrel=1
-pkgdesc="Enhanced continuation of the classic real-time strategy game Dune II"
-url="http://dunedynasty.sourceforge.net/"
+pkgdesc="Maintained fork of an enhanced continuation of the classic real-time strategy game Dune II"
+url="https://github.com/gameflorist/dunedynasty"
arch=('i686' 'x86_64')
-license=('GPL2')
-depends=('allegro')
+license=('GPL-2.0-only')
+depends=(
+ 'allegro'
+ 'alsa-lib'
+ 'enet'
+ 'libgl'
+)
makedepends=('cmake')
-optdepends=('fluidsynth: software synthesizer for midi music'
- 'soundfont-fluid: good soundfont for use with fluidsynth'
- 'timidity++: alternative midi sequencer'
- 'timidity-freepats: patch set for timidity++'
- 'libmad: for mp3 music support')
-install=$pkgname.install
-changelog=$pkgname.ChangeLog
-source=("http://downloads.sourceforge.net/$pkgname/$pkgname-$pkgver.tar.gz"
- "$pkgname.desktop")
-sha256sums=('a50e5a643db6835acb8cf7afd262b5eeba3fac01151ea51afcb1f5914d35a5c5'
- '4bc37a890a354e274b152a03fffa61d2da1609131c848742e1e4bca537176493')
+optdepends=(
+ 'fluidsynth: MIDI music support alternative'
+ 'soundfont-fluid: soundfont for fluidsynth'
+ 'timidity++: MIDI music support alternative'
+ 'timidity-freepats: patch set for timidity++'
+ 'libmad: MP3 music support'
+)
+install="${pkgname}.install"
+changelog=CHANGELOG.md
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/gameflorist/dunedynasty/archive/refs/tags/v${pkgver}.tar.gz")
+sha256sums=('97ca7af2423279674e4ac290a1c7d6ae85ad8a58b56108c8acceae829086a40f')
prepare() {
- cd $pkgname-$pkgver
+ cd "${pkgname}-${pkgver}"
- # set doc folder
- sed 's|doc/dunedynasty-${DUNE_DYNASTY_VERSION}|share/doc/dunedynasty|' -i CMakeLists.txt
- # set soundfont path
- sed 's|s/sf2/FluidR3_GM.sf2|fonts/FluidR3_GM2-2.sf2|' -i dist/dunedynasty.cfg-sample
+ # change doc directory to Archlinux conventions
+ sed \
+ -e 's|DESTINATION "doc/dunedynasty-${DUNE_DYNASTY_VERSION}")|DESTINATION "share/doc/dunedynasty")|' \
+ -i CMakeLists.txt
+
+ # default config settings for Archlinux in sample file
+ sed \
+ -e "s|^\s*\;\?s*sound_font\s*=\s*.*|sound_font=/usr/share/soundfonts/default.sf2|" \
+ -i dist/dunedynasty.cfg-sample
}
build() {
- cd $pkgname-$pkgver
+ cd "${pkgname}-${pkgver}"
+
+ # allow format-security errors in existing codebase until fixed upstream
+ CFLAGS="${CFLAGS} -Wno-error=format-security" \
+ cmake \
+ -S "${srcdir}/${pkgname}-${pkgver}" \
+ -B "${srcdir}/${pkgname}-${pkgver}/build" \
+ -DOpenGL_GL_PREFERENCE=GLVND \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DDUNE_DATA_DIR="/usr/share/${pkgname}"
- cmake ./ -DCMAKE_INSTALL_PREFIX=/usr -DDUNE_DATA_DIR=/usr/share/$pkgname
- make
+ cmake \
+ --build "${srcdir}/${pkgname}-${pkgver}/build" \
+ --config Release
}
package() {
- cd $pkgname-$pkgver
+ cd "${pkgname}-${pkgver}"
- make DESTDIR="$pkgdir/" install
+ DESTDIR="${pkgdir}" cmake \
+ --install "${srcdir}/${pkgname}-${pkgver}/build" \
+ --config Release
- # remove license, part of common licenses
- rm -f "$pkgdir"/usr/share/doc/$pkgname/COPYING
+ # remove common license file
+ rm -f "${pkgdir}/usr/share/doc/${pkgname}/LICENSE.txt"
- # desktop entry
- install -Dm644 src/video/dune2_32x32.xpm "$pkgdir"/usr/share/pixmaps/$pkgname.xpm
- install -Dm644 ../$pkgname.desktop "$pkgdir"/usr/share/applications/$pkgname.desktop
+ # desktop file and icon
+ install -Dm644 src/video/dune2_32x32.xpm "${pkgdir}/usr/share/pixmaps/${pkgname}.xpm"
+ install -Dm644 "dist/${pkgname}.desktop" "${pkgdir}/usr/share/applications/${pkgname}.desktop"
}
diff --git a/dunedynasty.ChangeLog b/dunedynasty.ChangeLog
deleted file mode 100644
index 57783aba1ea9..000000000000
--- a/dunedynasty.ChangeLog
+++ /dev/null
@@ -1,5 +0,0 @@
-2014-01-12 carstene1ns <url/mail: arch carsten-teibes de>
-
- * 1.5.7-1 :
- (package submitted)
- added .desktop file
diff --git a/dunedynasty.desktop b/dunedynasty.desktop
deleted file mode 100644
index ae663cd89218..000000000000
--- a/dunedynasty.desktop
+++ /dev/null
@@ -1,8 +0,0 @@
-[Desktop Entry]
-Name=Dune Dynasty
-Comment=Classic Dune. Modern Controls.
-Exec=dunedynasty
-Icon=dunedynasty
-Terminal=false
-Type=Application
-Categories=Game;
diff --git a/dunedynasty.install b/dunedynasty.install
index 0af9cc7e66bf..04ffd5892e23 100644
--- a/dunedynasty.install
+++ b/dunedynasty.install
@@ -1,11 +1,7 @@
-
post_install() {
- echo "Remember you need the DUNEII data files in '~/.local/share/dunedynasty/data'."
- echo "For midi music start 'timidity -iA -B 4,8' or set soundfont path for use"
- echo "with FluidSynth in '~/.config/dunedynasty/dunedynasty.cfg'"
- echo "For an example config file see '/usr/share/doc/dunedynasty' folder."
-}
-
-post_upgrade() {
- post_install
+ echo "Remember to place DUNE II data files in '~/.local/share/dunedynasty/data',"
+ echo "or the system-wide data directory '/usr/share/dunedynasty/data'."
+ echo "For MIDI music start 'timidity -iA -B 4,8', or set a soundfont path"
+ echo "for use with FluidSynth in '~/.config/dunedynasty/dunedynasty.cfg'"
+ echo "For an example config file, see '/usr/share/doc/dunedynasty/dunedynasty.cfg-sample'."
}