summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO25
-rw-r--r--PKGBUILD54
-rw-r--r--dunedynasty.desktop8
-rw-r--r--dunedynasty.install11
4 files changed, 98 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d8b56fae06b5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,25 @@
+pkgbase = dunedynasty
+ pkgdesc = Enhanced continuation of the classic real-time strategy game Dune II
+ pkgver = 1.5.7
+ pkgrel = 1
+ url = http://dunedynasty.sourceforge.net/
+ install = dunedynasty.install
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ makedepends = cmake
+ depends = allegro
+ optdepends = fluidsynth: software synthesizer for midi music
+ optdepends = fluidr3: good soundfont for use with fluidsynth
+ optdepends = timidity++: alternative midi sequencer
+ optdepends = timidity-freepats: patch set for timidity++
+ optdepends = libmad: for mp3 music support
+ source = http://downloads.sourceforge.net/dunedynasty/dunedynasty-1.5.7.tar.gz
+ source = dunedynasty.desktop
+ md5sums = 8ee5bddfb3a613657006edb70f57bb52
+ md5sums = SKIP
+ sha256sums = a50e5a643db6835acb8cf7afd262b5eeba3fac01151ea51afcb1f5914d35a5c5
+ sha256sums = SKIP
+
+pkgname = dunedynasty
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1baf6ddc66a1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,54 @@
+# Maintainer: carstene1ns <arch carsten-teibes de>
+
+pkgname=dunedynasty
+pkgver=1.5.7
+pkgrel=1
+pkgdesc="Enhanced continuation of the classic real-time strategy game Dune II"
+url="http://dunedynasty.sourceforge.net/"
+arch=('i686' 'x86_64')
+license=('GPL2')
+depends=('allegro')
+makedepends=('cmake')
+optdepends=('fluidsynth: software synthesizer for midi music'
+ 'fluidr3: good soundfont for use with fluidsynth'
+ 'timidity++: alternative midi sequencer'
+ 'timidity-freepats: patch set for timidity++'
+ 'libmad: for mp3 music support')
+install=$pkgname.install
+source=("http://downloads.sourceforge.net/$pkgname/$pkgname-$pkgver.tar.gz"
+ $pkgname.desktop)
+md5sums=('8ee5bddfb3a613657006edb70f57bb52'
+ 'SKIP')
+sha256sums=('a50e5a643db6835acb8cf7afd262b5eeba3fac01151ea51afcb1f5914d35a5c5'
+ 'SKIP')
+
+prepare() {
+ cd $pkgname-$pkgver
+
+ # set doc folder
+ sed -i 's|doc/dunedynasty-${DUNE_DYNASTY_VERSION}|share/doc/dunedynasty|' \
+ CMakeLists.txt
+ # set soundfont path
+ sed -i 's|s/sf2/FluidR3_GM.sf2|fonts/fluidr3/FluidR3GM.SF2|' \
+ dist/dunedynasty.cfg-sample
+}
+
+build() {
+ cd $pkgname-$pkgver
+
+ cmake ./ -DCMAKE_INSTALL_PREFIX=/usr -DDUNE_DATA_DIR=/usr/share/$pkgname
+ make
+}
+
+package() {
+ cd $pkgname-$pkgver
+
+ make DESTDIR="$pkgdir/" install
+
+ # remove license, part of common licenses
+ rm -f "$pkgdir"/usr/share/doc/$pkgname/COPYING
+
+ # desktop entry
+ install -Dm644 src/video/dune2_32x32.xpm "$pkgdir"/usr/share/pixmaps/$pkgname.xpm
+ install -Dm644 ../$pkgname.desktop "$pkgdir"/usr/share/applications/$pkgname.desktop
+}
diff --git a/dunedynasty.desktop b/dunedynasty.desktop
new file mode 100644
index 000000000000..ae663cd89218
--- /dev/null
+++ b/dunedynasty.desktop
@@ -0,0 +1,8 @@
+[Desktop Entry]
+Name=Dune Dynasty
+Comment=Classic Dune. Modern Controls.
+Exec=dunedynasty
+Icon=dunedynasty
+Terminal=false
+Type=Application
+Categories=Game;
diff --git a/dunedynasty.install b/dunedynasty.install
new file mode 100644
index 000000000000..cd4043ab14f8
--- /dev/null
+++ b/dunedynasty.install
@@ -0,0 +1,11 @@
+
+post_install() {
+ echo "Remember you need the DUNEII data files in ~/.local/share/dunedynasty/data"
+ echo "For midi music start 'timidity -iA -B 4,8' or set soundfont path for use"
+ echo "with FluidSynth in ~/.config/dunedynasty/dunedynasty.cfg"
+ echo "For an example config file see /usr/share/doc/dunedynasty folder."
+}
+
+post_upgrade() {
+ post_install
+}