summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD10
-rw-r--r--dunedynasty.install6
3 files changed, 8 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4a8525d2c4fe..97ad277ba3c2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -11,7 +11,7 @@ pkgbase = dunedynasty
makedepends = cmake
depends = allegro
optdepends = fluidsynth: software synthesizer for midi music
- optdepends = fluidr3: good soundfont for use with fluidsynth
+ optdepends = soundfont-fluid: good soundfont for use with fluidsynth
optdepends = timidity++: alternative midi sequencer
optdepends = timidity-freepats: patch set for timidity++
optdepends = libmad: for mp3 music support
diff --git a/PKGBUILD b/PKGBUILD
index aeda5333ddc4..c87c3a7399d7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,4 +1,4 @@
-# Maintainer: carstene1ns <arch carsten-teibes de>
+# Maintainer: carstene1ns <arch carsten-teibes de> - http://git.io/ctPKG
pkgname=dunedynasty
pkgver=1.5.7
@@ -10,7 +10,7 @@ license=('GPL2')
depends=('allegro')
makedepends=('cmake')
optdepends=('fluidsynth: software synthesizer for midi music'
- 'fluidr3: good soundfont for use with fluidsynth'
+ 'soundfont-fluid: good soundfont for use with fluidsynth'
'timidity++: alternative midi sequencer'
'timidity-freepats: patch set for timidity++'
'libmad: for mp3 music support')
@@ -25,11 +25,9 @@ prepare() {
cd $pkgname-$pkgver
# set doc folder
- sed -i 's|doc/dunedynasty-${DUNE_DYNASTY_VERSION}|share/doc/dunedynasty|' \
- CMakeLists.txt
+ sed 's|doc/dunedynasty-${DUNE_DYNASTY_VERSION}|share/doc/dunedynasty|' -i CMakeLists.txt
# set soundfont path
- sed -i 's|s/sf2/FluidR3_GM.sf2|fonts/fluidr3/FluidR3GM.SF2|' \
- dist/dunedynasty.cfg-sample
+ sed 's|s/sf2/FluidR3_GM.sf2|fonts/FluidR3_GM2-2.sf2|' -i dist/dunedynasty.cfg-sample
}
build() {
diff --git a/dunedynasty.install b/dunedynasty.install
index cd4043ab14f8..0af9cc7e66bf 100644
--- a/dunedynasty.install
+++ b/dunedynasty.install
@@ -1,9 +1,9 @@
post_install() {
- echo "Remember you need the DUNEII data files in ~/.local/share/dunedynasty/data"
+ echo "Remember you need the DUNEII data files in '~/.local/share/dunedynasty/data'."
echo "For midi music start 'timidity -iA -B 4,8' or set soundfont path for use"
- echo "with FluidSynth in ~/.config/dunedynasty/dunedynasty.cfg"
- echo "For an example config file see /usr/share/doc/dunedynasty folder."
+ echo "with FluidSynth in '~/.config/dunedynasty/dunedynasty.cfg'"
+ echo "For an example config file see '/usr/share/doc/dunedynasty' folder."
}
post_upgrade() {