summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD44
-rw-r--r--dunelegacy.changelog18
-rw-r--r--dunelegacy.install13
-rw-r--r--text_manager.patch11
5 files changed, 73 insertions, 32 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 42f6c3b49f88..1c2326cd78ee 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,20 @@
pkgbase = dunelegacy
pkgdesc = Updated clone of Westood Studios' Dune2
- pkgver = 0.96.3
- pkgrel = 2
+ pkgver = 0.97.02
+ pkgrel = 1
url = http://dunelegacy.sourceforge.net
- install = dunelegacy.install
changelog = dunelegacy.changelog
arch = i686
arch = x86_64
license = GPL
- depends = sdl_mixer
- depends = desktop-file-utils
- source = http://downloads.sourceforge.net/sourceforge/dunelegacy/dunelegacy-0.96.3-src.tar.bz2
- md5sums = 1ca64c06646aeb537d47f601a49463e9
+ makedepends = git
+ makedepends = autoconf
+ depends = sdl2_mixer
+ depends = sdl2_ttf
+ depends = xdg-utils
+ source = dunelegacy::git+https://git.code.sf.net/p/dunelegacy/code#commit=6ea9ac96854daa8c75ba429e78dc6716b147e106
+ source = text_manager.patch
+ md5sums = SKIP
+ md5sums = ee5ade548d7d5bbf1145b63be47183db
pkgname = dunelegacy
-
diff --git a/PKGBUILD b/PKGBUILD
index 7bed203a9c63..e5ce1c15b170 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,27 +1,49 @@
# Contributor: Angelo Theodorou <encelo@users.sourceforge.net>
pkgname=dunelegacy
-pkgver=0.96.3
-pkgrel=2
+pkgver=0.97.02
+pkgrel=1
pkgdesc="Updated clone of Westood Studios' Dune2"
arch=('i686' 'x86_64')
url="http://dunelegacy.sourceforge.net"
license=('GPL')
-depends=('sdl_mixer' 'desktop-file-utils')
+depends=('sdl2_mixer' 'sdl2_ttf' 'xdg-utils')
+makedepends=('git' 'autoconf')
changelog=dunelegacy.changelog
-install=dunelegacy.install
-source=(http://downloads.sourceforge.net/sourceforge/dunelegacy/$pkgname-$pkgver-src.tar.bz2)
-md5sums=('1ca64c06646aeb537d47f601a49463e9')
+source=($pkgname::git+https://git.code.sf.net/p/dunelegacy/code#commit=6ea9ac96854daa8c75ba429e78dc6716b147e106 text_manager.patch)
+md5sums=('SKIP' ee5ade548d7d5bbf1145b63be47183db)
+
+prepare() {
+ cd $pkgname
+ patch --forward --strip=1 --input="${srcdir}/text_manager.patch"
+}
build() {
- cd $srcdir/$pkgname-$pkgver
- ./configure --prefix=/usr
- make || return 1
+ cd $pkgname
+
+ autoreconf --install
+ mkdir -p build
+ cd build
+ ../configure --prefix="/usr" && make $1 && cp src/dunelegacy ../
}
package() {
- cd $srcdir/$pkgname-$pkgver
- make prefix=$pkgdir/usr install
+ cd $pkgname
+
+ install -Dm755 "dunelegacy" "$pkgdir/usr/bin/dunelegacy"
+
+ mkdir -p "$pkgdir/usr/share/dunelegacy"
+ install -m644 "data/LEGACY.PAK" "data/OPENSD2.PAK" "data/GFXHD.PAK" "data/Dune2-Versions.txt" "$pkgdir/usr/share/dunelegacy/"
+
+ mkdir -p "$pkgdir/usr/share/dunelegacy/locale"
+ cp -p data/locale/*.pot "$pkgdir/usr/share/dunelegacy/locale/"
+ cp -p data/locale/*.po "$pkgdir/usr/share/dunelegacy/locale/"
+
+ mkdir -p "$pkgdir/usr/share/dunelegacy/maps/singleplayer"
+ cp -p data/maps/singleplayer/*.ini "$pkgdir/usr/share/dunelegacy/maps/singleplayer/"
+
+ mkdir -p "$pkgdir/usr/share/dunelegacy/maps/multiplayer"
+ cp -p data/maps/multiplayer/*.ini "$pkgdir/usr/share/dunelegacy/maps/multiplayer/"
# install icon and desktop files
install -Dm644 "$pkgname.png" "$pkgdir/usr/share/pixmaps/$pkgname.png"
diff --git a/dunelegacy.changelog b/dunelegacy.changelog
index ed2ee5fcf4d7..17cd001c0295 100644
--- a/dunelegacy.changelog
+++ b/dunelegacy.changelog
@@ -1,3 +1,21 @@
+2023-06-14 Angelo "Encelo" Theodorou <encelo@users.sourceforge.net>
+
+ * PKGBUILD :
+ Updated the makedepends array
+ Add a patch to fix the compilation of the TextManager class
+ The patch to compile against the latest version of SDL2_mixer is not needed anymore
+
+2021-04-14 Angelo "Encelo" Theodorou <encelo@users.sourceforge.net>
+
+ * PKGBUILD :
+ Add a patch to compile with latest version of SDL2_mixer
+
+2017-01-02 Angelo "Encelo" Theodorou <encelo@users.sourceforge.net>
+
+ * PKGBUILD :
+ Updated dependencies array
+ Deleted the .install file
+
2013-04-12 Angelo "Encelo" Theodorou <encelo@users.sourceforge.net>
* PKGBUILD :
diff --git a/dunelegacy.install b/dunelegacy.install
deleted file mode 100644
index 88798b768050..000000000000
--- a/dunelegacy.install
+++ /dev/null
@@ -1,13 +0,0 @@
-
-post_install() {
- # updates for our .desktop file
- update-desktop-database -q
-}
-
-post_upgrade() {
- post_install $1
-}
-
-post_remove() {
- post_install $1
-}
diff --git a/text_manager.patch b/text_manager.patch
new file mode 100644
index 000000000000..704d9581471a
--- /dev/null
+++ b/text_manager.patch
@@ -0,0 +1,11 @@
+diff -ur dunelegacy.orig/include/FileClasses/TextManager.h dunelegacy/include/FileClasses/TextManager.h
+--- dunelegacy.orig/include/FileClasses/TextManager.h 2023-06-14 12:38:06.296181593 +0200
++++ dunelegacy/include/FileClasses/TextManager.h 2023-06-14 12:30:46.579528680 +0200
+@@ -21,6 +21,7 @@
+ #include "IndexedTextFile.h"
+ #include "MentatTextFile.h"
+
++#include <array>
+ #include <string>
+ #include <vector>
+ #include <map>