summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD34
-rw-r--r--dunelegacy-git.install9
3 files changed, 28 insertions, 26 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e62307a8eb9a..c90daed2aa2d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = dunelegacy-git
- pkgdesc = Updated clone of Westood Studios' Dune2 (Git version)
- pkgver = v0.96.3.8.g319cb34
+ pkgdesc = Updated clone of Westood Studios' Dune2 (development version)
+ pkgver = 0.96.4.r168.g6ea9ac9
pkgrel = 1
url = http://dunelegacy.sourceforge.net
install = dunelegacy-git.install
@@ -8,12 +8,11 @@ pkgbase = dunelegacy-git
arch = x86_64
license = GPL2
makedepends = git
- depends = sdl_mixer
+ depends = sdl2_mixer
+ depends = sdl2_ttf
provides = dunelegacy
conflicts = dunelegacy
- source = dunelegacy::git+https://dunelegacy.git.sourceforge.net/gitroot/dunelegacy/dunelegacy
+ source = dunelegacy::git+http://git.code.sf.net/p/dunelegacy/code
md5sums = SKIP
- sha256sums = SKIP
pkgname = dunelegacy-git
-
diff --git a/PKGBUILD b/PKGBUILD
index 26996e6fc59e..6cfa20a40162 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,34 +1,40 @@
-# Maintainer: carstene1ns <arch carsten-teibes de>
+# Maintainer: carstene1ns <arch carsten-teibes de> - http://git.io/ctPKG
_pkgbase=dunelegacy
pkgname=$_pkgbase-git
-pkgver=v0.96.3.8.g319cb34
+pkgver=0.96.4.r168.g6ea9ac9
pkgrel=1
-pkgdesc="Updated clone of Westood Studios' Dune2 (Git version)"
+pkgdesc="Updated clone of Westood Studios' Dune2 (development version)"
arch=('i686' 'x86_64')
url="http://dunelegacy.sourceforge.net"
license=('GPL2')
-depends=('sdl_mixer')
+depends=('sdl2_mixer' 'sdl2_ttf')
makedepends=('git')
conflicts=("$_pkgbase")
provides=("$_pkgbase")
install=$pkgname.install
-source=($_pkgbase::"git+https://dunelegacy.git.sourceforge.net/gitroot/dunelegacy/dunelegacy")
-sha256sums=('SKIP')
+source=($_pkgbase::"git+http://git.code.sf.net/p/dunelegacy/code")
md5sums=('SKIP')
pkgver() {
cd $_pkgbase
+ git describe --long --tags | sed 's/v//;s/-/.r/;s/-/./g'
+}
+
+prepare() {
+ cd $_pkgbase
+
+ autoreconf -fi
- local ver="$(git describe --long)"
- printf "%s" "${ver//-/.}"
+ # fix compilation, if needed
+ grep -q "<array>" include/FileClasses/TextManager.h ||
+ sed '/^#include <string>/i #include <array>' -i include/FileClasses/TextManager.h
}
build() {
cd $_pkgbase
- autoreconf --install
- ./configure --prefix=/usr
+ ./configure --prefix=/usr --enable-silent-rules
make
}
@@ -37,7 +43,9 @@ package() {
make DESTDIR="$pkgdir" install
- # install icon and desktop files
- install -Dm644 $_pkgbase.png "$pkgdir/usr/share/pixmaps/$_pkgbase.png"
- install -Dm644 $_pkgbase.desktop "$pkgdir/usr/share/applications/$_pkgbase.desktop"
+ # install icons and .desktop file
+ install -Dm644 $_pkgbase.png "$pkgdir"/usr/share/pixmaps/$_pkgbase.png
+ install -Dm644 $_pkgbase-128x128.png "$pkgdir"/usr/share/icons/hicolor/128x128/apps/$_pkgbase.png
+ install -Dm644 $_pkgbase.svg "$pkgdir"/usr/share/icons/hicolor/scalable/apps/$_pkgbase.svg
+ install -Dm644 $_pkgbase.desktop "$pkgdir"/usr/share/applications/$_pkgbase.desktop
}
diff --git a/dunelegacy-git.install b/dunelegacy-git.install
index 88798b768050..06ffb20ae0c7 100644
--- a/dunelegacy-git.install
+++ b/dunelegacy-git.install
@@ -1,13 +1,8 @@
post_install() {
- # updates for our .desktop file
- update-desktop-database -q
+ echo "Remember you have to put your DUNE II datafiles under ~/.config/dunelegacy/data/"
}
post_upgrade() {
- post_install $1
-}
-
-post_remove() {
- post_install $1
+ post_install
}