summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO30
-rw-r--r--PKGBUILD33
2 files changed, 63 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e340b1a17273
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,30 @@
+# Generated by mksrcinfo v8
+# Thu Apr 19 14:00:48 UTC 2018
+pkgbase = dunst-with-geometry-centering-git
+ pkgdesc = Lightweight and customizable notification daemon
+ pkgver = autogeneraated
+ pkgrel = 1
+ url = https://dunst-project.org/
+ arch = i686
+ arch = x86_64
+ arch = armv7h
+ license = BSD
+ makedepends = git
+ makedepends = perl
+ depends = libxinerama
+ depends = libxss
+ depends = pango
+ depends = libnotify
+ depends = gdk-pixbuf2
+ depends = libxdg-basedir
+ depends = libxrandr
+ provides = dunst
+ provides = notification-daemon
+ provides = dunstify
+ conflicts = dunst
+ conflicts = dunstify
+ source = git+https://github.com/dunst-project/dunst
+ md5sums = SKIP
+
+pkgname = dunst-with-geometry-centering-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6ff01d97841b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+pkgname=dunst-with-geometry-centering-git
+_pkgname=dunst
+pkgver=autogeneraated
+pkgrel=1
+pkgdesc="Lightweight and customizable notification daemon"
+arch=('i686' 'x86_64' 'armv7h')
+url="https://dunst-project.org/"
+license=('BSD')
+depends=('libxinerama' 'libxss' 'pango' 'libnotify' 'gdk-pixbuf2' 'libxdg-basedir' 'libxrandr')
+makedepends=('git' 'perl')
+provides=('dunst' 'notification-daemon' 'dunstify')
+conflicts=('dunst' 'dunstify')
+source=('git+https://github.com/dunst-project/dunst')
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$_pkgname"
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "${_pkgname}"
+ make X11INC=/usr/include/X11 X11LIB=/usr/lib/X11
+ make X11INC=/usr/include/X11 X11LIB=/usr/lib/X11 dunstify
+}
+
+package() {
+ cd "${_pkgname}"
+ make DESTDIR="${pkgdir}" PREFIX=/usr install
+ install -Dm755 dunstify "${pkgdir}"/usr/bin/dunstify
+ install -Dm755 contrib/dunst_espeak.sh "${pkgdir}"/usr/bin/dunst_espeak.sh
+ install -Dm644 LICENSE "${pkgdir}"/usr/share/licenses/${pkgname}/LICENSE
+}