summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rwxr-xr-xupdate_version.sh30
1 files changed, 30 insertions, 0 deletions
diff --git a/update_version.sh b/update_version.sh
new file mode 100755
index 000000000000..c0f8f52df100
--- /dev/null
+++ b/update_version.sh
@@ -0,0 +1,30 @@
+#!/bin/bash
+set -euxo pipefail
+
+# Read pkg name
+PKG=$(awk -F '=' '/pkgname=/{ print $2 }' PKGBUILD)
+
+# Get latest version
+VER=$(curl -sSfL "https://lv.luzifer.io/catalog-api/dust/latest.txt?p=version")
+
+# Insert latest version into PKGBUILD
+sed -i \
+ -e "s/^pkgver=.*/pkgver=${VER}/" \
+ -e 's/pkgrel=.*/pkgrel=1/' \
+ PKGBUILD
+
+# Check whether this changed anything
+if (git diff --exit-code PKGBUILD); then
+ echo "Package ${PKG} has most recent version ${VER}"
+ exit 0
+fi
+
+# Update source hashes
+updpkgsums
+
+# Update .SRCINFO
+makepkg --printsrcinfo >.SRCINFO
+
+# Commit changes
+git add PKGBUILD .SRCINFO
+git commit -m "${PKG} v${VER}"