summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rwxr-xr-xupdate_version.sh6
1 files changed, 5 insertions, 1 deletions
diff --git a/update_version.sh b/update_version.sh
index c0f8f52df100..439c9794d160 100755
--- a/update_version.sh
+++ b/update_version.sh
@@ -10,7 +10,6 @@ VER=$(curl -sSfL "https://lv.luzifer.io/catalog-api/dust/latest.txt?p=version")
# Insert latest version into PKGBUILD
sed -i \
-e "s/^pkgver=.*/pkgver=${VER}/" \
- -e 's/pkgrel=.*/pkgrel=1/' \
PKGBUILD
# Check whether this changed anything
@@ -19,6 +18,11 @@ if (git diff --exit-code PKGBUILD); then
exit 0
fi
+# Reset pkgrel
+sed -i \
+ -e 's/pkgrel=.*/pkgrel=1/' \
+ PKGBUILD
+
# Update source hashes
updpkgsums