summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD28
2 files changed, 42 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7520759db819
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = duviz-git
+ pkgdesc = Command line disk space usage visualization utility
+ pkgver = r48.3ae1f98
+ pkgrel = 1
+ url = http://soxofaan.github.com/duviz/
+ arch = any
+ license = GPL
+ makedepends = git
+ depends = python
+ source = git+https://github.com/soxofaan/duviz.git
+ md5sums = SKIP
+
+pkgname = duviz-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b18b1d97cacc
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: j605
+
+_gitname=duviz
+pkgname=$_gitname-git
+pkgver=r48.3ae1f98
+pkgrel=1
+pkgdesc='Command line disk space usage visualization utility'
+arch=('any')
+url="http://soxofaan.github.com/duviz/"
+license=('GPL')
+depends=('python')
+makedepends=('git')
+source=('git+https://github.com/soxofaan/duviz.git')
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$_gitname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ cd "$_gitname"
+ sed -i -e '1s:#!/usr/bin/env python:#!/usr/bin/python:' duviz.py
+}
+package() {
+ cd "$_gitname"
+ install -Dm 755 duviz.py ${pkgdir}/usr/bin/duviz
+}