summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD10
2 files changed, 10 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a7631cd136cc..7d63e9fde83c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,16 @@
pkgbase = dwl
pkgdesc = Simple, hackable dynamic tiling Wayland compositor (dwm for Wayland)
- pkgver = 0.3
+ pkgver = 0.4
pkgrel = 2
url = https://github.com/djpohly/dwl
arch = x86_64
license = GPL
makedepends = wayland-protocols
- depends = wlroots>=0.15
+ depends = wlroots>=0.16
optdepends = xorg-xwayland: for XWayland support
- source = dwl-0.3.tar.gz::https://github.com/djpohly/dwl/archive/v0.3.tar.gz
+ source = dwl-0.4.tar.gz::https://github.com/djpohly/dwl/archive/v0.4.tar.gz
source = config.h
- sha256sums = a3dd9b7107e9d324cc0dc4f48dd526fb687b10c9e63a42b33a827130d9113763
- sha256sums = SKIP
+ sha256sums = f03a260b169019ebdbfd6db1b19a3dc7861ba33609644581c530be019f22274c
+ sha256sums = e3b0c44298fc1c149afbf4c8996fb92427ae41e4649b934ca495991b7852b855
pkgname = dwl
diff --git a/PKGBUILD b/PKGBUILD
index fb5d25a4e8d0..62728205de18 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,18 +1,18 @@
# Maintainer: Devin J. Pohly <djpohly+arch@gmail.com>
pkgname=dwl
-pkgver=0.3
+pkgver=0.4
pkgrel=2
pkgdesc="Simple, hackable dynamic tiling Wayland compositor (dwm for Wayland)"
arch=('x86_64')
url="https://github.com/djpohly/dwl"
license=('GPL')
-depends=('wlroots>=0.15')
+depends=('wlroots>=0.16')
makedepends=('wayland-protocols')
optdepends=('xorg-xwayland: for XWayland support')
source=("$pkgname-$pkgver.tar.gz::https://github.com/djpohly/$pkgname/archive/v$pkgver.tar.gz"
config.h)
-sha256sums=('a3dd9b7107e9d324cc0dc4f48dd526fb687b10c9e63a42b33a827130d9113763'
- 'SKIP')
+sha256sums=('f03a260b169019ebdbfd6db1b19a3dc7861ba33609644581c530be019f22274c'
+ 'e3b0c44298fc1c149afbf4c8996fb92427ae41e4649b934ca495991b7852b855')
prepare() {
cd "$srcdir/$pkgname-$pkgver"
@@ -21,7 +21,7 @@ prepare() {
cp -f "$srcdir/config.h" config.h
fi
# Uncomment to compile with XWayland support
- #sed -i -e '/-DXWAYLAND/s/^#//' config.mk
+ #sed -i -e '/-DXWAYLAND\|xcb/s/^#//' config.mk
}
build() {