summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD21
2 files changed, 34 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8cb40ee7bf11
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = dwl
+ pkgdesc = Simple, hackable dynamic tiling Wayland compositor (dwm for Wayland)
+ pkgver = 0.1
+ pkgrel = 1
+ url = https://github.com/djpohly/dwl
+ arch = x86_64
+ license = GPL
+ depends = wlroots
+ source = https://github.com/djpohly/dwl/archive/v0.1.tar.gz
+ md5sums = SKIP
+
+pkgname = dwl
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0b5c0b202a7d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Maintainer: Devin J. Pohly <djpohly+arch@gmail.com>
+pkgname=dwl
+pkgver=0.1
+pkgrel=1
+pkgdesc="Simple, hackable dynamic tiling Wayland compositor (dwm for Wayland)"
+arch=('x86_64')
+url="https://github.com/djpohly/dwl"
+license=('GPL')
+depends=('wlroots')
+source=("https://github.com/djpohly/$pkgname/archive/v$pkgver.tar.gz")
+md5sums=('SKIP')
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+ make
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ make PREFIX="$pkgdir/usr/" install
+}