summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD7
2 files changed, 8 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 793c250b8f9d..cbc4442cd07a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,17 @@
pkgbase = dwl
pkgdesc = Simple, hackable dynamic tiling Wayland compositor (dwm for Wayland)
pkgver = 0.2.1
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/djpohly/dwl
arch = x86_64
license = GPL
makedepends = wayland-protocols
depends = wlroots>=0.13
+ optdepends = xorg-xwayland: for XWayland support
source = https://github.com/djpohly/dwl/archive/v0.2.1.tar.gz
source = config.h
sha256sums = 4c65ba86608adc0d37414ebfaf814957d3349518e44f3cc6f50f5f3bd827c150
- sha256sums = 0bf53ab668252bf63b25e1b3ea76ace85c0dd3cd49e16168e85a3b49f4a3c708
+ sha256sums = SKIP
pkgname = dwl
diff --git a/PKGBUILD b/PKGBUILD
index 88940bebff05..75f4b0faa27b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,21 +1,24 @@
# Maintainer: Devin J. Pohly <djpohly+arch@gmail.com>
pkgname=dwl
pkgver=0.2.1
-pkgrel=1
+pkgrel=2
pkgdesc="Simple, hackable dynamic tiling Wayland compositor (dwm for Wayland)"
arch=('x86_64')
url="https://github.com/djpohly/dwl"
license=('GPL')
depends=('wlroots>=0.13')
makedepends=('wayland-protocols')
+optdepends=('xorg-xwayland: for XWayland support')
source=("https://github.com/djpohly/$pkgname/archive/v$pkgver.tar.gz"
config.h)
sha256sums=('4c65ba86608adc0d37414ebfaf814957d3349518e44f3cc6f50f5f3bd827c150'
- '0bf53ab668252bf63b25e1b3ea76ace85c0dd3cd49e16168e85a3b49f4a3c708')
+ 'SKIP')
prepare() {
cd "$srcdir/$pkgname-$pkgver"
cp "$srcdir/config.h" config.h
+ # Uncomment to compile with XWayland support
+ #sed -i -e '/-DXWAYLAND/s/^#//' config.mk
}
build() {