summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO13
-rwxr-xr-xPKGBUILD16
-rwxr-xr-xconfig.def.h.work154
-rwxr-xr-xconfig.def.h.x200s (renamed from config.def.h)19
4 files changed, 187 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6afedae2ab0a..cf3dd3c6f160 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = dwm-uleenucks-git
pkgdesc = A dynamic window manager for X
- pkgver = 6.1
- pkgrel = 1
+ pkgver = 6.1.5.g56a31dc
+ pkgrel = 2
epoch = 1
url = https://git.uleenucks.de/builds/
install = dwm.install
@@ -14,12 +14,17 @@ pkgbase = dwm-uleenucks-git
depends = libxft
provides = dwm
conflicts = dwm
+ replaces = dwm
options = zipman
source = dwm::git+http://git.suckless.org/dwm
- source = config.def.h
+ source = config.def.h.x200s
+ source = config.def.h.work
+ source = compile.sh
source = dwm-6.1-center.diff
md5sums = SKIP
- md5sums = 596c20f45d805c872789037a338a358d
+ md5sums = 53acc5aead54700e3709e0d33fe5d252
+ md5sums = ac89a24396a42dee2922c06d31388c5e
+ md5sums = 2fb39fa984c6676363051d0bafc74dc6
md5sums = 5f6f840c692f43f7e349bb87e895ff26
pkgname = dwm-uleenucks-git
diff --git a/PKGBUILD b/PKGBUILD
index 2dbd12db8646..ea332de639dc 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,12 +1,12 @@
pkgname=dwm-uleenucks-git
_pkgname=dwm
pkgdesc="dwm with uleenucks personalisations"
-pkgver=6.1
+pkgver=6.1.5.g56a31dc
pkgver(){
cd $_pkgname
git describe --tags |sed 's/-/./g'
}
-pkgrel=1
+pkgrel=2
pkgdesc="A dynamic window manager for X"
url="https://git.uleenucks.de/builds/"
arch=('i686' 'x86_64')
@@ -17,12 +17,20 @@ makedepends=('git')
install=dwm.install
provides=('dwm')
conflicts=('dwm')
+replaces=('dwm')
epoch=1
source=("$_pkgname::git+http://git.suckless.org/dwm"
- config.def.h
+ config.def.h.x200s
+ config.def.h.work
+ compile.sh
dwm-6.1-center.diff)
-. md5sums
+md5sums=('SKIP'
+ '53acc5aead54700e3709e0d33fe5d252'
+ 'ac89a24396a42dee2922c06d31388c5e'
+ '2fb39fa984c6676363051d0bafc74dc6'
+ '5f6f840c692f43f7e349bb87e895ff26')
+
prepare() {
if [[ -f $SRCDEST/config.def.h ]]; then
ln -sf $SRCDEST/config.def.h $srcdir/dwm/config.h
diff --git a/config.def.h.work b/config.def.h.work
new file mode 100755
index 000000000000..8fba0f8afdb7
--- /dev/null
+++ b/config.def.h.work
@@ -0,0 +1,154 @@
+/* See LICENSE file for copyright and license details. */
+
+/* appearance */
+static const char *fonts[] = {
+ "Erusfont:size=8",
+ "VL Gothic:size=10.5",
+ "WenQuanYi Micro Hei:size=10.5",
+};
+static const char font[] = "-*-proggyoptis-*-*-*-*-11-*-*-*-*-*-*-*";
+static const unsigned int borderpx = 1; /* border pixel of windows */
+static const unsigned int snap = 32; /* snap pixel */
+static const unsigned int systraypinning = 0; /* 0: sloppy systray follows selected monitor, >0: pin systray to monitor X */
+static const unsigned int systrayspacing = 2; /* systray spacing */
+static const Bool systraypinningfailfirst = True; /* True: if pinning fails, display systray on the first monitor, False: display systray on the last monitor*/
+static const Bool showsystray = True; /* False means no systray */
+static const int nmaster = 2; /* number of clients in master area */
+static const Bool showbar = True; /* False means no bar */
+static const Bool topbar = True; /* False means bottom bar */
+static const char normbordercolor[] = "#080808";
+static const char normbgcolor[] = "#080808";
+static const char normfgcolor[] = "#ffffff";
+static const char selbordercolor[] = "#c6c6c6";
+static const char selbgcolor[] = "#c6c6c6";
+static const char selfgcolor[] = "#dc322f";
+static const char *colors[SchemeLast][3] = {
+ /* fg bg border */
+ [SchemeNorm] = { normfgcolor, normbgcolor, normbordercolor },
+ [SchemeSel] = { selfgcolor, selbgcolor, selbordercolor },
+};
+
+/* tagging */
+static const char *tags[] = { "1/main", "2/web", "3/stuff", "4/office" };
+
+static const Rule rules[] = {
+ /* class instance title tags mask iscentered isfloating monitor */
+ /* monitor 0 */
+ { "Wine", NULL, NULL, 1 << 1, True, True, 0 },
+ { "Remmina", NULL, NULL, 1 << 1, True, True, 0 },
+ { "calibre-gui", NULL, NULL, 1 << 1, True, True, 0 },
+ { "PacketTracer6", NULL, NULL, 1 << 1, True, True, 0 },
+ { "VirtualBox", NULL, NULL, 1 << 1, True, True, 0 },
+ /* monitor 1 */
+ { "chromium", NULL, NULL, 1 << 1, False, False, 1 },
+ { "google-chrome-beta", NULL, NULL, 1 << 1, False, False, 1 },
+ { NULL, "Browser", NULL, 1 << 1, True, True, 1 },
+ { NULL, "dwb", NULL, 1 << 1, False, False, 1 },
+ { "Firefox", NULL, NULL, 1 << 1, False, False, 1 },
+ { "KeePass2", NULL, "Auto-Type Entry Selection", 1 << 1, True, True, 1 },
+ { "Gajim", NULL, NULL, 1 << 2, True, True, 1 },
+ { "KeePass2", NULL, NULL, 1 << 2, True, True, 1 },
+ { "Corebird", NULL, NULL, 1 << 2, True, True, 1 },
+ { "Spotify", NULL, NULL, 1 << 2, True, True, 1 },
+ { "LibreOffice", NULL, NULL, 1 << 0, False, False, 1 },
+ /* everywhere */
+ { "Gimp", NULL, NULL, 1 << 2, False, True, -1 },
+ { "feh", NULL, NULL, 0, True, True, -1 },
+ { "Sxiv", NULL, NULL, 0, True, True, -1 },
+ { "mpv", NULL, NULL, 0, True, True, -1 },
+ { "Wine", NULL, NULL, 0, True, True, -1 },
+ { "XFontSel", NULL, NULL, 0, True, True, -1 },
+ { NULL, "xterm", NULL, 0, True, True, -1 },
+ { "Zathura", NULL, NULL, 0, True, True, -1 },
+ { NULL, NULL, "Save file", 0, True, True, -1 },
+ { NULL, NULL, "Wicd Network Manager", 0, True, True, -1 },
+};
+
+/* layout(s) */
+static const float mfact = 0.50; /* factor of master area size [0.05..0.95] */
+static const Bool resizehints = False; /* True means respect size hints in tiled resizals */
+
+static const Layout layouts[] = {
+ /* symbol arrange function */
+ { "[T]", tile }, /* first entry is default */
+ { "[M]", monocle }, /* maximized */
+ { "><>", NULL }, /* floating */
+};
+
+/* key definitions */
+#define MODKEY Mod4Mask
+#define TAGKEYS(KEY,TAG) \
+ { MODKEY, KEY, view, {.ui = 1 << TAG} }, \
+ { MODKEY|ControlMask, KEY, toggleview, {.ui = 1 << TAG} }, \
+ { MODKEY|ShiftMask, KEY, tag, {.ui = 1 << TAG} }, \
+ { MODKEY|ControlMask|ShiftMask, KEY, toggletag, {.ui = 1 << TAG} },
+
+/* helper for spawning shell commands in the pre dwm-5.0 fashion */
+#define SHCMD(cmd) { .v = (const char*[]){ "/bin/sh", "-c", cmd, NULL } }
+
+/* commands */
+static char dmenumon[2] = "0"; /* component of dmenucmd, manipulated in spawn() */
+static const char *dmenucmd[] = { "dmenu_run", "-m", dmenumon, "-fn", font, "-nb", normbgcolor, "-nf", normfgcolor, "-sb", selbgcolor, "-sf", selfgcolor, NULL };
+static const char *termcmd[] = { "tmuxattach.sh", NULL };
+static const char *mostusedcmd[] = { "mostused", NULL };
+static const char *lockcmd[] = { "slock", NULL };
+static const char *passcmd[] = { "keepass", "--auto-type", NULL };
+
+static Key keys[] = {
+ /* modifier key function argument */
+ { MODKEY, XK_p, spawn, {.v = dmenucmd } },
+ { MODKEY, XK_v, spawn, {.v = mostusedcmd } },
+ { MODKEY|ShiftMask, XK_Return, spawn, {.v = termcmd } },
+ { MODKEY|ShiftMask, XK_l, spawn, {.v = lockcmd } },
+ { ControlMask|Mod1Mask, XK_a, spawn, {.v = passcmd } },
+ { MODKEY|ShiftMask, XK_b, togglebar, {0} },
+ { MODKEY, XK_j, focusstack, {.i = +1 } },
+ { MODKEY, XK_k, focusstack, {.i = -1 } },
+ { MODKEY, XK_h, setmfact, {.f = -0.05} },
+ { MODKEY, XK_l, setmfact, {.f = +0.05} },
+ { MODKEY, XK_Return, zoom, {0} },
+ { MODKEY, XK_Tab, view, {0} },
+ { MODKEY|ShiftMask, XK_c, killclient, {0} },
+ { MODKEY, XK_a, incnmaster, {.i = +1 } },
+ { MODKEY, XK_z, incnmaster, {.i = -1 } },
+ { MODKEY, XK_t, setlayout, {.v = &layouts[0]} },
+ { MODKEY, XK_b, setlayout, {.v = &layouts[1]} },
+ { MODKEY, XK_m, setlayout, {.v = &layouts[2]} },
+ { MODKEY, XK_f, setlayout, {.v = &layouts[3]} },
+ { MODKEY, XK_space, setlayout, {0} },
+ { MODKEY|ShiftMask, XK_space, togglefloating, {0} },
+ { MODKEY, XK_0, view, {.ui = ~0 } },
+ { MODKEY|ShiftMask, XK_0, tag, {.ui = ~0 } },
+ { MODKEY, XK_comma, focusmon, {.i = -1 } },
+ { MODKEY, XK_period, focusmon, {.i = +1 } },
+ { MODKEY|ShiftMask, XK_comma, tagmon, {.i = -1 } },
+ { MODKEY|ShiftMask, XK_period, tagmon, {.i = +1 } },
+ TAGKEYS( XK_1, 0)
+ TAGKEYS( XK_2, 1)
+ TAGKEYS( XK_3, 2)
+ TAGKEYS( XK_4, 3)
+ TAGKEYS( XK_5, 4)
+ TAGKEYS( XK_6, 5)
+ TAGKEYS( XK_7, 6)
+ TAGKEYS( XK_8, 7)
+ TAGKEYS( XK_9, 8)
+ { MODKEY|ShiftMask, XK_q, quit, {0} },
+};
+
+/* button definitions */
+/* click can be ClkLtSymbol, ClkStatusText, ClkWinTitle, ClkClientWin, or ClkRootWin */
+static Button buttons[] = {
+ /* click event mask button function argument */
+ { ClkLtSymbol, 0, Button1, setlayout, {0} },
+ { ClkLtSymbol, 0, Button3, setlayout, {.v = &layouts[2]} },
+ { ClkWinTitle, 0, Button2, zoom, {0} },
+ { ClkStatusText, 0, Button2, spawn, {.v = termcmd } },
+ { ClkClientWin, MODKEY, Button1, movemouse, {0} },
+ { ClkClientWin, MODKEY, Button2, togglefloating, {0} },
+ { ClkClientWin, MODKEY, Button3, resizemouse, {0} },
+ { ClkTagBar, 0, Button1, view, {0} },
+ { ClkTagBar, 0, Button3, toggleview, {0} },
+ { ClkTagBar, MODKEY, Button1, tag, {0} },
+ { ClkTagBar, MODKEY, Button3, toggletag, {0} },
+};
+
diff --git a/config.def.h b/config.def.h.x200s
index 6d4e0f05f969..d55abacb8866 100755
--- a/config.def.h
+++ b/config.def.h.x200s
@@ -7,12 +7,6 @@ static const char *fonts[] = {
"WenQuanYi Micro Hei:size=10.5",
};
static const char font[] = "-*-proggyoptis-*-*-*-*-11-*-*-*-*-*-*-*";
-static const char normbordercolor[] = "#002b36";
-static const char normbgcolor[] = "#002b36";
-static const char normfgcolor[] = "#839496";
-static const char selbordercolor[] = "#0066ff";
-static const char selbgcolor[] = "#073642";
-static const char selfgcolor[] = "#cb4b16";
static const unsigned int borderpx = 1; /* border pixel of windows */
static const unsigned int snap = 32; /* snap pixel */
static const unsigned int systraypinning = 0; /* 0: sloppy systray follows selected monitor, >0: pin systray to monitor X */
@@ -22,6 +16,17 @@ static const Bool showsystray = True; /* False means no systray */
static const int nmaster = 2; /* number of clients in master area */
static const Bool showbar = True; /* False means no bar */
static const Bool topbar = True; /* False means bottom bar */
+static const char normbordercolor[] = "#080808";
+static const char normbgcolor[] = "#080808";
+static const char normfgcolor[] = "#ffffff";
+static const char selbordercolor[] = "#c6c6c6";
+static const char selbgcolor[] = "#c6c6c6";
+static const char selfgcolor[] = "#dc322f";
+static const char *colors[SchemeLast][3] = {
+ /* fg bg border */
+ [SchemeNorm] = { normfgcolor, normbgcolor, normbordercolor },
+ [SchemeSel] = { selfgcolor, selbgcolor, selbordercolor },
+};
/* tagging */
static const char *tags[] = { "1/main", "2/web", "3/stuff", "4/office" };
@@ -33,7 +38,7 @@ static const Rule rules[] = {
{ "Remmina", NULL, NULL, 1 << 1, True, True, 0 },
{ "calibre-gui", NULL, NULL, 1 << 1, True, True, 0 },
{ "VirtualBox", NULL, NULL, 1 << 1, True, True, 0 },
- { "Chromium", NULL, NULL, 1 << 1, False, False, 0 },
+ { "chromium", NULL, NULL, 1 << 1, False, False, 0 },
{ "google-chrome-beta", NULL, NULL, 1 << 1, False, False, 0 },
{ NULL, "Browser", NULL, 1 << 1, True, True, 0 },
{ NULL, "dwb", NULL, 1 << 1, False, False, 0 },