summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD27
-rw-r--r--PKGBUILD.live23
3 files changed, 35 insertions, 29 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 47381c88c56e..71cd14304199 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = dxvk-mingw
pkgdesc = Vulkan-based implementation of D3D9, D3D10 and D3D11 for Linux / Wine, MingW version
- pkgver = 1.10.3
+ pkgver = 2.0
pkgrel = 1
url = https://github.com/doitsujin/dxvk
arch = x86_64
@@ -15,18 +15,22 @@ pkgbase = dxvk-mingw
depends = bash
provides = dxvk
provides = d9vk
- provides = dxvk=1.10.3
+ provides = dxvk=2.0
conflicts = dxvk
conflicts = d9vk
options = !lto
options = !staticlibs
- source = git+https://github.com/doitsujin/dxvk.git#tag=v1.10.3
- source = dxvk-async-1111b69.patch::https://raw.githubusercontent.com/Sporif/dxvk-async/1111b69/dxvk-async.patch
+ source = git+https://github.com/doitsujin/dxvk.git
+ source = git+https://github.com/KhronosGroup/Vulkan-Headers.git
+ source = git+https://github.com/KhronosGroup/SPIRV-Headers.git
+ source = dxvk-async-8665e60.patch::https://raw.githubusercontent.com/Sporif/dxvk-async/8665e60/dxvk-async.patch
source = dxvk-async-conf.patch
source = dxvk-extraopts.patch
source = setup_dxvk
sha256sums = SKIP
- sha256sums = 14e9011b9aa40fe3dcc7a248735eec717a525aa2866e2bba5fd6fa5662c3dec0
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = 85877b6ea801b3a139797628415ac5c74ec87ce16d1d3c434f5c36b00922833d
sha256sums = c9c2f02bce1e1e93d511aff73484208456835d4d7601a36ab4524939472fc401
sha256sums = bcc15521e4c7f966a0192a1dabb7fb4935b33db39344ab5b861f9d81486f1362
sha256sums = c1f6a18b03d1612b60f8081428f00cfac5e66315fe9d42719f01cf5564deeeff
diff --git a/PKGBUILD b/PKGBUILD
index 3a7afbebcaa4..88fa30225b28 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: loathingkernel <loathingkernel @at gmail .dot com>
pkgname=dxvk-mingw
-pkgver=1.10.3
-_asyncver=1111b69
+pkgver=2.0
+_asyncver=8665e60
pkgrel=1
pkgdesc='Vulkan-based implementation of D3D9, D3D10 and D3D11 for Linux / Wine, MingW version'
arch=('x86_64')
@@ -14,7 +14,9 @@ provides=('dxvk' 'd9vk' "dxvk=$pkgver")
conflicts=('dxvk' 'd9vk')
options=(!lto !staticlibs)
source=(
- "git+https://github.com/doitsujin/dxvk.git#tag=v$pkgver"
+ "git+https://github.com/doitsujin/dxvk.git"
+ "git+https://github.com/KhronosGroup/Vulkan-Headers.git"
+ "git+https://github.com/KhronosGroup/SPIRV-Headers.git"
"dxvk-async-${_asyncver}.patch::https://raw.githubusercontent.com/Sporif/dxvk-async/${_asyncver}/dxvk-async.patch"
"dxvk-async-conf.patch"
"dxvk-extraopts.patch"
@@ -24,6 +26,11 @@ source=(
prepare() {
cd dxvk
+ git submodule init include/{vulkan,spirv}
+ git submodule set-url include/vulkan "$srcdir/Vulkan-Headers"
+ git submodule set-url include/spirv "$srcdir/SPIRV-Headers"
+ git -c protocol.file.allow=always submodule update include/{vulkan,spirv}
+
# Uncomment to enable dxvk async patch.
# Enable at your own risk. If you don't know what it is,
# and its implications, leave it as is. You have been warned.
@@ -80,22 +87,20 @@ prepare() {
}
build() {
- meson dxvk "build/x64" \
+ meson setup dxvk "build/x64" \
--cross-file dxvk/build-win64.txt \
--prefix "/usr/share/dxvk/x64" \
--bindir "" --libdir "" \
--buildtype "plain" \
- --strip \
- -Denable_tests=false
+ --strip
ninja -C "build/x64" -v
- meson dxvk "build/x32" \
+ meson setup dxvk "build/x32" \
--cross-file dxvk/build-win32.txt \
--prefix "/usr/share/dxvk/x32" \
--bindir "" --libdir "" \
--buildtype "plain" \
- --strip \
- -Denable_tests=false
+ --strip
ninja -C "build/x32" -v
}
@@ -110,7 +115,9 @@ package() {
}
sha256sums=('SKIP'
- '14e9011b9aa40fe3dcc7a248735eec717a525aa2866e2bba5fd6fa5662c3dec0'
+ 'SKIP'
+ 'SKIP'
+ '85877b6ea801b3a139797628415ac5c74ec87ce16d1d3c434f5c36b00922833d'
'c9c2f02bce1e1e93d511aff73484208456835d4d7601a36ab4524939472fc401'
'bcc15521e4c7f966a0192a1dabb7fb4935b33db39344ab5b861f9d81486f1362'
'c1f6a18b03d1612b60f8081428f00cfac5e66315fe9d42719f01cf5564deeeff')
diff --git a/PKGBUILD.live b/PKGBUILD.live
index 62d101d7797e..14c79ea65d33 100644
--- a/PKGBUILD.live
+++ b/PKGBUILD.live
@@ -1,7 +1,7 @@
# Maintainer: loathingkernel <loathingkernel @at gmail .dot com>
pkgname=dxvk-mingw
-pkgver=1.10.3
+pkgver=2.0.r0.g8f8a9369
_asyncver=master
pkgrel=1
pkgdesc='Vulkan-based implementation of D3D9, D3D10 and D3D11 for Linux / Wine, MingW version'
@@ -15,7 +15,6 @@ conflicts=('dxvk' 'd9vk')
options=(!lto !staticlibs)
source=(
"git+https://github.com/doitsujin/dxvk.git"
- "git+https://github.com/Joshua-Ashton/mingw-directx-headers.git"
"git+https://github.com/KhronosGroup/Vulkan-Headers.git"
"git+https://github.com/KhronosGroup/SPIRV-Headers.git"
"dxvk-async-${_asyncver}.patch::https://raw.githubusercontent.com/Sporif/dxvk-async/${_asyncver}/dxvk-async.patch"
@@ -32,11 +31,10 @@ pkgver() {
prepare() {
cd dxvk
- git submodule init include/{native/directx,vulkan,spirv}
- git config submodule.include/native/directx.url "$srcdir/mingw-directx-headers"
- git config submodule.include/vulkan.url "$srcdir/Vulkan-Headers"
- git config submodule.include/spirv.url "$srcdir/SPIRV-Headers"
- git submodule update include/{native/directx,vulkan,spirv}
+ git submodule init include/{vulkan,spirv}
+ git submodule set-url include/vulkan "$srcdir/Vulkan-Headers"
+ git submodule set-url include/spirv "$srcdir/SPIRV-Headers"
+ git -c protocol.file.allow=always submodule update include/{vulkan,spirv}
# Uncomment to enable dxvk async patch.
# Enable at your own risk. If you don't know what it is,
@@ -94,22 +92,20 @@ prepare() {
}
build() {
- meson dxvk "build/x64" \
+ meson setup dxvk "build/x64" \
--cross-file dxvk/build-win64.txt \
--prefix "/usr/share/dxvk/x64" \
--bindir "" --libdir "" \
--buildtype "plain" \
- --strip \
- -Denable_tests=false
+ --strip
ninja -C "build/x64" -v
- meson dxvk "build/x32" \
+ meson setup dxvk "build/x32" \
--cross-file dxvk/build-win32.txt \
--prefix "/usr/share/dxvk/x32" \
--bindir "" --libdir "" \
--buildtype "plain" \
- --strip \
- -Denable_tests=false
+ --strip
ninja -C "build/x32" -v
}
@@ -127,7 +123,6 @@ sha256sums=('SKIP'
'SKIP'
'SKIP'
'SKIP'
- 'SKIP'
'c9c2f02bce1e1e93d511aff73484208456835d4d7601a36ab4524939472fc401'
'bcc15521e4c7f966a0192a1dabb7fb4935b33db39344ab5b861f9d81486f1362'
'c1f6a18b03d1612b60f8081428f00cfac5e66315fe9d42719f01cf5564deeeff')