summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD11
-rw-r--r--build.patch77
-rw-r--r--e4rat_0.2.3_src.tar.gzbin0 -> 72459 bytes
4 files changed, 87 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f6505b46e759..42854d0e91ea 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = e4rat
pkgdesc = Toolset to accelerate the boot process and application startups for systems with ext4 root partitions.
pkgver = 0.2.3
- pkgrel = 4
+ pkgrel = 5
url = http://e4rat.sourceforge.net/
arch = i686
arch = x86_64
@@ -29,12 +29,13 @@ pkgbase = e4rat
source = boost-fs3-v2.patch
source = cmake_boost.patch
source = cmake.patch
+ source = build.patch
sha256sums = f6feda9618eff0f9442baf771b4776b634e5a2f39e678c10e4c7946b2c6a96a0
sha256sums = d54959ea7fb0629de51f6b530ee72082863756bbe0b0b5af0965aa5ad9ac9739
sha256sums = ea35d1f7f8b6c4be9f20cc6ffbe72446dbdb6b99df450f29855a1cf9cf79362a
sha256sums = 9a9786d6167e4a47d1733735745b0eadeabf487886405df9e6771a28f3a20965
sha256sums = 0978a893f73dbd16ef727b59f865cb9079dd3a357f43188308a1ea303177dd02
sha256sums = 626f5663c6d5690c119e2e21402ce352285d0771806cc7119ba6e4c785e6e3b1
+ sha256sums = f045addc960ec356f4063528a6a9e0a2abf8bd8e6b04e70f7fb54db75c9382cc
pkgname = e4rat
-
diff --git a/PKGBUILD b/PKGBUILD
index 5cafccce6f9c..b5144366d01f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
pkgname=e4rat
pkgver=0.2.3
-pkgrel=4
+pkgrel=5
pkgdesc="Toolset to accelerate the boot process and application startups for systems with ext4 root partitions."
arch=('i686' 'x86_64')
url="http://e4rat.sourceforge.net/"
@@ -21,7 +21,8 @@ source=( "http://downloads.sourceforge.net/project/$pkgname/$pkgver/e4rat_${pkgv
'sysmacros_h.patch' \
'boost-fs3-v2.patch'
'cmake_boost.patch'
- 'cmake.patch')
+ 'cmake.patch'
+ 'build.patch')
prepare () {
cd "$srcdir/$pkgname-$pkgver"
@@ -30,11 +31,12 @@ prepare () {
patch -p0 -i ../sysmacros_h.patch
patch -p1 -i ../cmake_boost.patch
patch -p0 -i ../cmake.patch
+ patch -p1 -i ../build.patch
}
build() {
cd "$srcdir/$pkgname-$pkgver"
- cmake -DCMAKE_BUILD_TYPE=Release -DBUILD_CORE_LIBRARY_STATIC=true -DCMAKE_INSTALL_PREFIX="/usr" .
+ cmake -DCMAKE_BUILD_TYPE=Release -DBUILD_CORE_LIBRARY_STATIC=true -DCMAKE_INSTALL_PREFIX="/usr" .
make
}
@@ -50,4 +52,5 @@ sha256sums=('f6feda9618eff0f9442baf771b4776b634e5a2f39e678c10e4c7946b2c6a96a0'
'ea35d1f7f8b6c4be9f20cc6ffbe72446dbdb6b99df450f29855a1cf9cf79362a'
'9a9786d6167e4a47d1733735745b0eadeabf487886405df9e6771a28f3a20965'
'0978a893f73dbd16ef727b59f865cb9079dd3a357f43188308a1ea303177dd02'
- '626f5663c6d5690c119e2e21402ce352285d0771806cc7119ba6e4c785e6e3b1')
+ '626f5663c6d5690c119e2e21402ce352285d0771806cc7119ba6e4c785e6e3b1'
+ 'f045addc960ec356f4063528a6a9e0a2abf8bd8e6b04e70f7fb54db75c9382cc')
diff --git a/build.patch b/build.patch
new file mode 100644
index 000000000000..0b4051b275e4
--- /dev/null
+++ b/build.patch
@@ -0,0 +1,77 @@
+diff --git a/src/defrag.cc b/src/defrag.cc
+index 4a0815b..198b24c 100644
+--- a/src/defrag.cc
++++ b/src/defrag.cc
+@@ -24,6 +24,7 @@
+ #include "config.hh"
+ #include "buddycache.hh"
+
++#include <cmath>
+ #include <errno.h>
+ #include <sys/stat.h>
+ #include <fcntl.h>
+diff --git a/src/device.hh b/src/device.hh
+index fd881df..7318b65 100644
+--- a/src/device.hh
++++ b/src/device.hh
+@@ -21,6 +21,8 @@
+ #define DEVICE_HH
+
+ #include "common.hh"
++
++#include <boost/shared_ptr.hpp>
+ #include <string>
+ #include <ext2fs/ext2fs.h>
+ #include <ext2fs/ext2_fs.h>
+diff --git a/src/e4rat-collect.cc b/src/e4rat-collect.cc
+index 8309ade..8397a0d 100644
+--- a/src/e4rat-collect.cc
++++ b/src/e4rat-collect.cc
+@@ -421,7 +421,7 @@ int main(int argc, char* argv[])
+ if( Config::get<bool>("ext4_only"))
+ listener.watchExt4Only();
+
+- CONNECT(&listener, eventParsed, boost::bind(&EventCatcher::handleAuditEvent, &project, _1));
++ CONNECT(&listener, eventParsed, boost::bind(&EventCatcher::handleAuditEvent, &project, boost::placeholders::_1));
+
+
+ if(execute || 1 == getpid())
+diff --git a/src/listener.cc b/src/listener.cc
+index e7ba5e1..81e6065 100644
+--- a/src/listener.cc
++++ b/src/listener.cc
+@@ -153,12 +153,7 @@ void AuditListener::watchFileSystemType(long t)
+
+ void addSyscall(struct audit_rule_data* rule, const char* sc, int machine)
+ {
+- int syscall_nr;
+- syscall_nr = audit_name_to_syscall(sc, machine);
+- if(syscall_nr == -1)
+- throw std::logic_error("Cannot convert syscall to number");
+-
+- audit_rule_syscall_data(rule, syscall_nr);
++ audit_rule_syscallbyname_data(rule, sc);
+ }
+
+ void AuditListener::activateRules(int machine)
+diff --git a/src/signals.hh b/src/signals.hh
+index f050adf..7704d0e 100644
+--- a/src/signals.hh
++++ b/src/signals.hh
+@@ -42,11 +42,11 @@
+ #include <boost/signals2/signal.hpp>
+
+ //get the number of arguments
+-#define BIND1ST _1
+-#define BIND2ST _1,_2
+-#define BIND3ST _1,_2,_3
+-#define BIND4ST _1,_2,_3,_4
+-#define BIND5ST _1,_2,_3,_4,_5
++#define BIND1ST boost::placeholders::_1
++#define BIND2ST boost::placeholders::_1, boost::placeholders::_2
++#define BIND3ST boost::placeholders::_1, boost::placeholders::_2, boost::placeholders::_3
++#define BIND4ST boost::placeholders::_1, boost::placeholders::_2, boost::placeholders::_3, boost::placeholders::_4
++#define BIND5ST boost::placeholders::_1, boost::placeholders::_2, boost::placeholders::_3, boost::placeholders::_4, boost::placeholders::_5
+
+ #define VA_NUM_ARGS(...) VA_NUM_ARGS_IMPL(__VA_ARGS__, \
+ BIND5ST, \
diff --git a/e4rat_0.2.3_src.tar.gz b/e4rat_0.2.3_src.tar.gz
new file mode 100644
index 000000000000..ec500c86317e
--- /dev/null
+++ b/e4rat_0.2.3_src.tar.gz
Binary files differ