summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD28
2 files changed, 39 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ff2853b0b02e..5ccca0c7b46e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,24 @@
pkgbase = eagle
pkgdesc = Powerful suite for schematic capture and printed circuit board design (aka eaglecad)
pkgver = 9.6.2
- pkgrel = 1
+ pkgrel = 2
url = http://www.autodesk.com/products/eagle
arch = x86_64
license = custom
depends = desktop-file-utils
depends = shared-mime-info
+ depends = krb5
+ depends = libxcb
+ depends = libx11
+ depends = e2fsprogs
+ depends = libglvnd
+ depends = libxext
+ depends = fontconfig
+ depends = libxi
+ depends = freetype2
+ depends = pcre
+ depends = libcups
+ depends = dbus
options = !emptydirs
options = !strip
source = https://eagle-updates.circuits.io/downloads/9_6_2/Autodesk_EAGLE_9.6.2_English_Linux_64bit.tar.gz
@@ -16,9 +28,8 @@ pkgbase = eagle
source = eagle.xml
sha256sums = 0086b3fddcd9eaeead0f30f814b868a9e0ef75fbdf6185ec3448d0a9edf35ea3
sha256sums = d8f8adf45c8c136030f877975aed22ec97c6e26f6aa2218905c7b14b51bc1334
- sha256sums = 2037dd28ed9d6c2f41a3e6d2fde59c3f1c27b203093be26a7d8c8cea69bcd272
+ sha256sums = 3ad7f6657842a7733289f46cafa877e069913a2deb63b268162def97aa3a4079
sha256sums = 40e5a40cea787c0e823946271031744fdd9c755363da97d6dd4bea1eee7ee6b6
sha256sums = 293ef717030e171903ba555a5c698e581f056d2a33884868018ab2af96a94a06
pkgname = eagle
-
diff --git a/PKGBUILD b/PKGBUILD
index 7c0e5921c842..686f6c847a90 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,12 +7,12 @@
pkgname=eagle
pkgver=9.6.2
-pkgrel=1
+pkgrel=2
pkgdesc="Powerful suite for schematic capture and printed circuit board design (aka eaglecad)"
arch=('x86_64')
url="http://www.autodesk.com/products/eagle"
license=('custom')
-depends=('desktop-file-utils' 'shared-mime-info')
+depends=('desktop-file-utils' 'shared-mime-info' 'krb5' 'libxcb' 'libx11' 'e2fsprogs' 'libglvnd' 'libxext' 'fontconfig' 'libxi' 'freetype2' 'pcre' 'libcups' 'dbus')
options=(!emptydirs !strip)
source=(# Official source according to website:
# "http://trial2.autodesk.com/NET17SWDLD/2017/EGLPRM/ESD/Autodesk_EAGLE_${pkgver}_English_Linux_64bit.tar.gz"
@@ -60,10 +60,32 @@ package() {
rm "$pkgdir"/opt/$pkgname/lib/libx*
rm "$pkgdir"/opt/$pkgname/lib/libX*
- # Fix permissions (necessary since 8.5.2)
+ # Remove libglapi which seems to cause segfaults on some systems.
+ rm "$pkgdir"/opt/$pkgname/lib/libglapi*
+
+ # Remove remaining libraries that are provided by Arch packages and not Qt-related.
+ rm "$pkgdir"/opt/$pkgname/lib/libEGL*
+ rm "$pkgdir"/opt/$pkgname/lib/libavahi*
+ rm "$pkgdir"/opt/$pkgname/lib/libdbus*
+ rm "$pkgdir"/opt/$pkgname/lib/libfreebl*
+ rm "$pkgdir"/opt/$pkgname/lib/libgbm*
+ rm "$pkgdir"/opt/$pkgname/lib/libgmodule*
+ rm "$pkgdir"/opt/$pkgname/lib/libgthread*
+ rm "$pkgdir"/opt/$pkgname/lib/libkrb5*
+ rm "$pkgdir"/opt/$pkgname/lib/libpcre*
+ rm "$pkgdir"/opt/$pkgname/lib/libpl*
+ rm "$pkgdir"/opt/$pkgname/lib/libsmime*
+
+ # We cannot use Arch's Qt5 due to the following errors:
+ # QXcbIntegration: Cannot create platform OpenGL context, neither GLX nor EGL are enabled
+ # /opt/eagle/eagle: symbol lookup error: /opt/eagle/plugins/bearer/libqconnmanbearer.so: undefined symbol: _ZdlPvm, version Qt_5
+ # rm "$pkgdir"/opt/$pkgname/lib/libQt*
+
+ # Fix file permissions
find "$pkgdir" -perm 750 -exec chmod 755 {} \;
find "$pkgdir" -perm 700 -exec chmod 755 {} \;
find "$pkgdir" -perm 640 -exec chmod 644 {} \;
find "$pkgdir" -perm 600 -exec chmod 644 {} \;
+ chmod 755 "$pkgdir"/opt/eagle/lib/libSuits.so
}