summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD18
2 files changed, 16 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index abcedad64086..b805316988ca 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,13 @@
pkgbase = easyabc
pkgdesc = A graphical music notation editor for the ABC music notation language
- pkgver = 182
+ pkgver = 305
pkgrel = 1
url = https://github.com/jwdj/EasyABC
arch = any
license = GPL
makedepends = gendesk
makedepends = git
- depends = python-wxpython
- depends = python-pyparsing
- depends = python-pygame
+ depends = python39
depends = abcmidi
depends = abcm2ps
depends = ghostscript
@@ -19,4 +17,3 @@ pkgbase = easyabc
md5sums = SKIP
pkgname = easyabc
-
diff --git a/PKGBUILD b/PKGBUILD
index 369b7235a324..608981ca3f5a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,13 +3,14 @@
# Contributor: Simon Thorpe <simon@hivetechnology.com.au>
pkgname=easyabc
-pkgver=182
+pkgver=305
pkgrel=1
pkgdesc="A graphical music notation editor for the ABC music notation language"
arch=('any')
url="https://github.com/jwdj/EasyABC"
license=('GPL')
-depends=('python-wxpython' 'python-pyparsing' 'python-pygame' 'abcmidi' 'abcm2ps' 'ghostscript')
+#depends=('python-wxpython' 'python-pyparsing' 'python-pygame' 'abcmidi' 'abcm2ps' 'ghostscript')
+depends=('python39' 'abcmidi' 'abcm2ps' 'ghostscript')
makedepends=('gendesk' 'git')
provides=($pkgname)
conflicts=($pkgname)
@@ -35,12 +36,21 @@ package(){
install -dm755 "$pkgdir"/opt/easyabc
cp -dpr --no-preserve=ownership "${pkgname}" $pkgdir/opt/
- echo -e '#!/bin/bash\npython /opt/easyabc/easy_abc.py "$@"' > $pkgdir/usr/bin/easyabc
+ echo -e '#!/bin/bash\n/opt/easyabc/bin/python /opt/easyabc/easy_abc.py "$@"' > $pkgdir/usr/bin/easyabc
chmod +x $pkgdir/usr/bin/easyabc
install -Dm644 "${pkgname}/img/logo64.png" "$pkgdir/usr/share/pixmaps/$pkgname.png"
install -Dm644 "$pkgname.desktop" "$pkgdir/usr/share/applications/$pkgname.desktop"
+
+ cd "$pkgdir"/opt
+ python3.9 -m venv easyabc
+ source easyabc/bin/activate
+ pip install --upgrade pip
+ pip install wxpython==4.1.1 --use-pep517
+ pip install pyparsing
+ pip install pygame
+
ln -s /usr/bin/abc2abc $pkgdir/opt/easyabc/bin/
ln -s /usr/bin/abc2midi $pkgdir/opt/easyabc/bin/
ln -s /usr/bin/abcm2ps $pkgdir/opt/easyabc/bin/
-} \ No newline at end of file
+}