summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD23
2 files changed, 40 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..dbd0d2088f7b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = easybuild-easyconfigs-git
+ pkgdesc = A software build and installation framework for HPC systems
+ pkgver = 3.5.1.r142.g0c1a5150e
+ pkgrel = 1
+ url = https://github.com/easybuilders/easybuild-easyconfigs
+ arch = any
+ groups = easybuild-git
+ license = GPL
+ makedepends = git
+ makedepends = python2-setuptools
+ depends = python2
+ depends = easybuild-easyblocks-git
+ source = git+https://github.com/easybuilders/easybuild-easyconfigs.git#branch=develop
+ md5sums = SKIP
+
+pkgname = easybuild-easyconfigs-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..46733d7f162b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Hans-Nikolai Viessmann <hv15 AT hw.ac.uk>
+pkgname='easybuild-easyconfigs-git'
+pkgver=3.5.1.r142.g0c1a5150e
+pkgrel=1
+pkgdesc="A software build and installation framework for HPC systems"
+arch=('any')
+groups=('easybuild-git')
+url="https://github.com/easybuilders/easybuild-easyconfigs"
+license=('GPL')
+depends=('python2' 'easybuild-easyblocks-git')
+makedepends=('git' 'python2-setuptools')
+source=('git+https://github.com/easybuilders/easybuild-easyconfigs.git#branch=develop')
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/easybuild-easyconfigs"
+ printf "%s" "$(git describe --long | sed 's/\([^-]*-g\)/r\1/;s/.*v\(.*\)$/\1/;s/-/./g')"
+}
+
+package() {
+ cd "$srcdir/easybuild-easyconfigs"
+ python2 setup.py install --root "$pkgdir"
+}