summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD20
2 files changed, 33 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a4d66d471249
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = easyeda2kicad
+ pkgdesc = Convert EasyEDA designs to KiCad EDA
+ pkgver = 1.9.2
+ pkgrel = 1
+ url = https://github.com/wokwi/easyeda2kicad
+ arch = any
+ license = MIT
+ makedepends = npm
+ source = easyeda2kicad-1.9.2.tar.gz::https://github.com/wokwi/easyeda2kicad/archive/refs/tags/v1.9.2.tar.gz
+ sha256sums = 378fff1370e85b4cbd5956fc53907b7de90ae8f910d53ba13c98fecac416fb23
+
+pkgname = easyeda2kicad
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6cf55632128b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,20 @@
+# Maintainer: Rafael Silva <perigoso@riseup.net>
+
+pkgname=easyeda2kicad
+pkgver=1.9.2
+pkgrel=1
+pkgdesc="Convert EasyEDA designs to KiCad EDA"
+arch=('any')
+url="https://github.com/wokwi/easyeda2kicad"
+makedepends=('npm')
+license=('MIT')
+#noextract=("${pkgname}-${pkgver}.tar.gz")
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/wokwi/${pkgname}/archive/refs/tags/v${pkgver}.tar.gz")
+sha256sums=('378fff1370e85b4cbd5956fc53907b7de90ae8f910d53ba13c98fecac416fb23')
+
+package() {
+ cd ${pkgname}-${pkgver}
+ npm install -g --prefix "${pkgdir}/usr" ${pkgname}
+ find "${pkgdir}/usr" -type d -exec chmod 755 {} +
+ chown -R root:root "${pkgdir}"
+}