summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD31
2 files changed, 15 insertions, 22 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ebd356552d12..19d42dcc23f9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,18 @@
pkgbase = easyrpg-editor-qt-git
pkgdesc = EasyRPG's Game Editor (QT, development version)
- pkgver = r298.98a486d
+ pkgver = r308.5b413b5
pkgrel = 1
url = https://easy-rpg.org/
install = easyrpg-editor-qt-git.install
arch = i686
arch = x86_64
- license = unknown
+ license = GPL3
makedepends = git
depends = liblcf-git
depends = qt5-multimedia
provides = easyrpg-editor-qt
conflicts = easyrpg-editor-qt
- source = easyrpg-editor-qt::git+https://github.com/EasyRPG/editor-qt.git
+ source = easyrpg-editor-qt::git+https://github.com/EasyRPG/Editor-QT.git
md5sums = SKIP
pkgname = easyrpg-editor-qt-git
diff --git a/PKGBUILD b/PKGBUILD
index ae08b52a17ef..a1675e2f2bbf 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,45 +1,38 @@
-# Maintainer: carstene1ns <url/mail: arch carsten-teibes de>
+# Maintainer: carstene1ns <arch carsten-teibes de> - http://git.io/ctPKG
pkgname=easyrpg-editor-qt-git
-pkgver=r298.98a486d
+pkgver=r308.5b413b5
pkgrel=1
pkgdesc="EasyRPG's Game Editor (QT, development version)"
arch=('i686' 'x86_64')
url="https://easy-rpg.org/"
-license=('unknown')
-conflicts=('easyrpg-editor-qt')
-provides=('easyrpg-editor-qt')
+license=('GPL3')
+conflicts=("${pkgname%-*}")
+provides=("${pkgname%-*}")
makedepends=('git')
depends=('liblcf-git' 'qt5-multimedia')
install="$pkgname.install"
-source=(easyrpg-editor-qt::"git+https://github.com/EasyRPG/editor-qt.git")
+source=(${pkgname%-*}::"git+https://github.com/EasyRPG/Editor-QT.git")
md5sums=('SKIP')
pkgver() {
- cd easyrpg-editor-qt
+ cd ${pkgname%-*}
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
-prepare() {
- cd easyrpg-editor-qt
- # set include folder for liblcf and reorder libraries
- sed -e 's|$$PWD/libs/liblcf/src|/usr/include/liblcf|;/liblcf\/generated/d' \
- -e 's|-lexpat -llcf|-llcf -lexpat|' -i EasyRPG-Editor.pro
-}
-
build () {
- cd easyrpg-editor-qt
+ cd ${pkgname%-*}
qmake-qt5
make
}
package () {
- cd easyrpg-editor-qt/bin
+ cd ${pkgname%-*}/bin
# binary
- install -Dm755 EasyRPG-Editor "$pkgdir"/usr/bin/easyrpg-editor-qt
+ install -Dm755 EasyRPG-Editor "$pkgdir"/usr/bin/${pkgname%-*}
# templates
- install -d "$pkgdir"/usr/share/easyrpg-editor-qt/templates
- install -m644 templates/* "$pkgdir"/usr/share/easyrpg-editor-qt/templates
+ install -d "$pkgdir"/usr/share/${pkgname%-*}/templates
+ install -m644 templates/* "$pkgdir"/usr/share/${pkgname%-*}/templates
}