summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD35
2 files changed, 12 insertions, 33 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 26c22b8a3603..71515e31f5a9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,12 @@
pkgbase = ebgaramond-otf
- pkgdesc = EB Garamond (OTF version) by Octavio Pardo & Georg Duffner
+ pkgdesc = font (OTF version) by Octavio Pardo & Georg Duffner
pkgver = 1.0
pkgrel = 1
url = https://github.com/octaviopardo/EBGaramond12
arch = any
- license = custom:OFL
- depends = fontconfig
- depends = xorg-font-utils
- source = https://github.com/octaviopardo/EBGaramond12/archive/master.zip
- sha256sums = a08f5d1e0ad1976330e1c5e57faf384a27628323eaacf797644a3c42bcabac73
+ license = OFL
+ source = https://github.com/octaviopardo/EBGaramond12/archive/8e8d2aff04abb39fceca0b1e8da1f444e466fb3b.zip
+ sha256sums = 08c82a332338a474862f7123f0b6c5c7a4256288f890049bcf989d1564c73856
pkgname = ebgaramond-otf
diff --git a/PKGBUILD b/PKGBUILD
index 9fe0e5251e9c..f1abbdc11f1e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,38 +1,19 @@
# Maintainer: Sam Simons <contact at sam-simons dot nl>
-# (Loosely) based on otf-inter by Ward Segers & otf-eb-garamond by OmeGa
+# Maintainer: Lennard Hofmann <lennard dot hofmann at web dot de>
pkgname=ebgaramond-otf
_pkgname=EBGaramond12
+_commit=8e8d2aff04abb39fceca0b1e8da1f444e466fb3b
pkgver=1.0
pkgrel=1
-pkgdesc='EB Garamond (OTF version) by Octavio Pardo & Georg Duffner'
+pkgdesc='font (OTF version) by Octavio Pardo & Georg Duffner'
arch=('any')
url='https://github.com/octaviopardo/EBGaramond12'
-license=('custom:OFL')
-depends=('fontconfig' 'xorg-font-utils')
-source=("https://github.com/octaviopardo/$_pkgname/archive/master.zip")
-sha256sums=('a08f5d1e0ad1976330e1c5e57faf384a27628323eaacf797644a3c42bcabac73')
+license=('OFL')
+source=("https://github.com/octaviopardo/$_pkgname/archive/$_commit.zip")
+sha256sums=('08c82a332338a474862f7123f0b6c5c7a4256288f890049bcf989d1564c73856')
package() {
- cd "$_pkgname-master"
+ cd "$_pkgname-$_commit"
install -Dm644 OFL.txt "$pkgdir/usr/share/licenses/$pkgname/OFL.txt"
-
- cd "fonts/otf"
- install -d "$pkgdir/usr/share/fonts/$_pkgname-otf"
- install -m644 *.otf "$pkgdir/usr/share/fonts/$_pkgname-otf/"
-}
-
-post_install() {
- echo -n "Updating font cache... "
- fc-cache -s
- mkfontscale "/usr/share/fonts/$_pkgname-otf"
- mkfontdir "/usr/share/fonts/$_pkgname-otf"
- echo "done."
-}
-
-post_upgrade() {
- post_install $1
-}
-
-post_remove() {
- post_install $1
+ install -Dm644 fonts/otf/*.otf -t "$pkgdir/usr/share/fonts/$_pkgname-otf/"
}