summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO24
-rw-r--r--Makefile.patch10
-rw-r--r--PKGBUILD48
-rw-r--r--ebook-viewer.install8
4 files changed, 90 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..19f3c376bfaf
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+pkgbase = ebook-viewer-git
+ pkgdesc = Modern GTK Python Ebook Reader app to easily read epub files
+ pkgver = r77.2350a74
+ pkgrel = 1
+ url = https://github.com/michaldaniel/Ebook-Viewer/
+ install = ebook-viewer.install
+ arch = any
+ license = GPL3
+ makedepends = git
+ makedepends = make
+ depends = python
+ depends = gtk3
+ depends = gobject-introspection
+ depends = libwebkit3
+ depends = python-gobject
+ provides = ebook-viewer
+ conflicts = ebook-viewer
+ source = ebook-viewer::git+https://github.com/michaldaniel/Ebook-Viewer.git#branch=master
+ source = Makefile.patch
+ sha256sums = SKIP
+ sha256sums = 20b83b38d7939652d19d473ff1769d481793cdca56d3d87e17261874b8563316
+
+pkgname = ebook-viewer-git
+
diff --git a/Makefile.patch b/Makefile.patch
new file mode 100644
index 000000000000..b01f76f97fd8
--- /dev/null
+++ b/Makefile.patch
@@ -0,0 +1,10 @@
+--- Makefile 2016-12-08 00:07:30.596899373 +0100
++++ Makefile 2016-12-08 00:10:59.820236503 +0100
+@@ -61,7 +61,6 @@
+ ${PREFIX}/share/icons/hicolor/scalable/apps/easy-ebook-viewer.svg
+ install -m 644 misc/easy-ebook-viewer.desktop \
+ ${PREFIX}/share/applications/easy-ebook-viewer.desktop
+- gtk-update-icon-cache -f ${PREFIX}/share/icons/hicolor/
+
+ clean:
+ rm -f easy-ebook-viewer
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c17dcef44829
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,48 @@
+# Maintainer: Johannes Schriewer <hallo@dunkelstern.de>
+pkgname=ebook-viewer-git
+pkgver=r77.2350a74
+pkgrel=1
+pkgdesc="Modern GTK Python Ebook Reader app to easily read epub files"
+arch=('any')
+url="https://github.com/michaldaniel/Ebook-Viewer/"
+license=('GPL3')
+groups=()
+depends=('python' 'gtk3' 'gobject-introspection' 'libwebkit3' 'python-gobject')
+makedepends=('git' 'make')
+optdepends=()
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+replaces=()
+backup=()
+options=()
+install='ebook-viewer.install'
+changelog=
+source=(
+ 'ebook-viewer::git+https://github.com/michaldaniel/Ebook-Viewer.git#branch=master'
+ 'Makefile.patch'
+)
+noextract=()
+sha256sums=(
+ 'SKIP'
+ '20b83b38d7939652d19d473ff1769d481793cdca56d3d87e17261874b8563316'
+)
+
+pkgver() {
+ cd "$srcdir/${pkgname%-git}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ cd "$srcdir/${pkgname%-git}"
+ patch <"$srcdir/Makefile.patch"
+}
+
+build() {
+ cd "$srcdir/${pkgname%-git}"
+ make PREFIX=/usr
+}
+
+package() {
+ cd "$srcdir/${pkgname%-git}"
+ make PREFIX="$pkgdir/usr" install
+}
diff --git a/ebook-viewer.install b/ebook-viewer.install
new file mode 100644
index 000000000000..1ef9ae9b9119
--- /dev/null
+++ b/ebook-viewer.install
@@ -0,0 +1,8 @@
+post_install() {
+ echo "Updating GTK icon cache..."
+ gtk-update-icon-cache -f /usr/share/icons/hicolor/
+}
+
+post_upgrade() {
+ post_install $1
+}