summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO7
-rw-r--r--.gitlab-ci.yml4
-rw-r--r--Dockerfile.build_and_test2
-rw-r--r--PKGBUILD12
4 files changed, 9 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1402b26c55f6..3efdcd9533b2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,15 @@
pkgbase = eccodes
pkgdesc = ECMWF decoding library for GRIB, BUFR and GTS
pkgver = 2.21.0
- pkgrel = 1
+ pkgrel = 2
url = https://software.ecmwf.int/wiki/display/ECC/ecCodes+Home
arch = i686
arch = x86_64
license = Apache
makedepends = gcc-fortran
makedepends = cmake
- depends = openjpeg
- depends = libpng
+ depends = openjpeg2
depends = netcdf
- optdepends = libaec: for compression
- optdepends = jasper: as an alternative to openjpeg
conflicts = grib_api
conflicts = libbufr-ecmwf
source = http://software.ecmwf.int/wiki/download/attachments/45757960/eccodes-2.21.0-Source.tar.gz
diff --git a/.gitlab-ci.yml b/.gitlab-ci.yml
index b66ce725790f..9f8bfa006aa6 100644
--- a/.gitlab-ci.yml
+++ b/.gitlab-ci.yml
@@ -64,11 +64,11 @@ test-eccodes:
image: ${CI_REGISTRY_IMAGE}/${BUILD_AND_TEST_IMAGE}:${CI_COMMIT_REF_NAME}
needs: ["build-eccodes"]
script:
+ # Try to install package
+ - sudo pacman -U --noconfirm eccodes*.pkg.tar.zst
# Recommended checks
- namcap -m PKGBUILD
- namcap -m eccodes*.pkg.tar.zst
- # Try to install package
- - sudo pacman -U --noconfirm eccodes*.pkg.tar.zst
deploy-eccodes:
stage: deploy
diff --git a/Dockerfile.build_and_test b/Dockerfile.build_and_test
index 6ac1cfc93b00..f109bb7d5512 100644
--- a/Dockerfile.build_and_test
+++ b/Dockerfile.build_and_test
@@ -3,7 +3,7 @@ ARG REGISTRY
FROM "$REGISTRY/common/gitlab-helper/archlinux-yay:master"
RUN (\
- yay -Syuq --noconfirm --needed openjpeg libpng netcdf \
+ yay -Syuq --noconfirm --needed openjpeg2 netcdf \
&& yes | yay -Scc --noconfirm \
&& sudo rm -rf /var/cache/pacman/pkg/* \
)
diff --git a/PKGBUILD b/PKGBUILD
index 11ec2d595ba0..38fb4a670628 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,13 +3,12 @@
pkgname=eccodes
pkgver=2.21.0
_attnum=45757960
-pkgrel=1
+pkgrel=2
pkgdesc="ECMWF decoding library for GRIB, BUFR and GTS"
arch=('i686' 'x86_64')
url="https://software.ecmwf.int/wiki/display/ECC/ecCodes+Home"
license=('Apache')
-depends=('openjpeg' 'libpng' 'netcdf')
-optdepends=('libaec: for compression' 'jasper: as an alternative to openjpeg')
+depends=('openjpeg2' 'netcdf')
makedepends=('gcc-fortran' 'cmake')
conflicts=('grib_api' 'libbufr-ecmwf')
source=(http://software.ecmwf.int/wiki/download/attachments/${_attnum}/${pkgname}-${pkgver}-Source.tar.gz)
@@ -17,16 +16,13 @@ sha512sums=('f2ba8361b99800646a92f5f5beb7ec2facf2ee3b8a3f7985d9681a23b2faae77800
build() {
cd "$srcdir"/${pkgname}-${pkgver}-Source
- sed -i 's/image.inmem_.*=.*1;//' src/grib_jasper_encoding.c
mkdir -p build
cd build
- [ $(pacman -Qq libaec 2>/dev/null) ] && use_aec="ON" || use_aec="OFF"
- [ $(pacman -Qq jasper 2>/dev/null) ] && use_jasper="ON" || use_jasper="OFF"
cmake -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_BUILD_TYPE=production \
-DCMAKE_INSTALL_DATAROOTDIR=/usr/share/$pkgname/definitions \
- -DCMAKE_INSTALL_DATADIR=/usr/share -DENABLE_AEC=$use_aec \
+ -DCMAKE_INSTALL_DATADIR=/usr/share -DENABLE_AEC=ON \
-DENABLE_PNG=ON -DENABLE_ECCODES_THREADS=ON -DENABLE_JPG=ON \
- -DENABLE_JPG_LIBOPENJPEG=ON -DENABLE_JPG_LIBJASPER=$use_jasper ..
+ -DENABLE_JPG_LIBOPENJPEG=ON -DENABLE_JPG_LIBJASPER=OFF ..
make
}