summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD36
-rw-r--r--ecity.desktop10
3 files changed, 61 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c8170831b4d7
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = ecity
+ pkgdesc = Virtual City Environment for Engineering Problem Based Learning
+ pkgver = 1.5.1
+ pkgrel = 1
+ url = http://ecity-project.eu
+ arch = i686
+ arch = x86_64
+ license = GPL
+ source = http://ecity-project.eu/ecity-1.5.1-linux.zip
+ source = ecity.desktop
+ md5sums = 140ba9db9ac7042a8312c9b449a40d5b
+ md5sums = b22d47c4787a9e15e96c9fcf1b733848
+
+pkgname = ecity
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9dc04e5860b7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Ricardo Gonçalves <ricardompgoncalves@gmail.com>
+
+pkgname=ecity
+pkgver=1.5.1
+pkgrel=1
+pkgdesc="Virtual City Environment for Engineering Problem Based Learning"
+arch=('i686' 'x86_64')
+url="http://ecity-project.eu"
+license=('GPL')
+depends=()
+source=("http://ecity-project.eu/${pkgname}-${pkgver}-linux.zip"
+ "${pkgname}.desktop")
+md5sums=('140ba9db9ac7042a8312c9b449a40d5b'
+ 'b22d47c4787a9e15e96c9fcf1b733848')
+
+package() {
+ # Create directories
+ mkdir -pv "${pkgdir}/opt/${pkgname}"
+ mkdir -pv "${pkgdir}/usr/bin"
+ mkdir -pv "${pkgdir}/usr/share/applications/"
+
+ # Move files
+ cp "${pkgname}.desktop" "${pkgdir}/usr/share/applications/"
+ cp "${pkgname}-${pkgver}_Data/Resources/UnityPlayer.png" "${pkgdir}/opt/${pkgname}/${pkgname}.png"
+ mv "${pkgname}-${pkgver}_Data" "${pkgdir}/opt/${pkgname}/"
+ mv "${pkgname}-${pkgver}.x86" "${pkgdir}/opt/${pkgname}/"
+
+ # Create links
+ ln -sv "/opt/${pkgname}/${pkgname}-${pkgver}.x86" "${pkgdir}/opt/${pkgname}/${pkgname}"
+
+ echo \#\!/bin/sh > "${pkgdir}/opt/${pkgname}/${pkgname}.sh"
+ echo "/opt/${pkgname}/${pkgname}" >> "${pkgdir}/opt/${pkgname}/${pkgname}.sh"
+ chmod a+x "${pkgdir}/opt/${pkgname}/${pkgname}.sh"
+ ln -sv "/opt/${pkgname}/${pkgname}.sh" "${pkgdir}/usr/bin/${pkgname}"
+}
+
diff --git a/ecity.desktop b/ecity.desktop
new file mode 100644
index 000000000000..7ecec8091909
--- /dev/null
+++ b/ecity.desktop
@@ -0,0 +1,10 @@
+[Desktop Entry]
+Name=ecity
+Comment=Virtual City Environment for Engineering Problem Based Learning
+Exec=ecity %U
+Icon=/opt/ecity/ecity.png
+Terminal=false
+Type=Application
+Encoding=UTF-8
+Categories=Game;
+Name[en_US]=ecity