summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD20
2 files changed, 34 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c0ab6898c274
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = eclipse-ivyde
+ pkgdesc = Eclipse plugin which integrates Apache Ivy's dependency management
+ pkgver = 2.2.0.final
+ pkgrel = 1
+ url = https://ant.apache.org/ivy/ivyde/
+ arch = any
+ license = apache
+ depends = eclipse
+ depends = eclipse-ivyde-ivy
+ source = http://mirrors.ukfast.co.uk/sites/ftp.apache.org/ant/ivyde/2.2.0.final/apache-ivyde-2.2.0.final-201311091524-RELEASE.tar.gz
+ md5sums = 7bed9c2bcf920e7e29735f62a78495c3
+
+pkgname = eclipse-ivyde
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..32b208a15f96
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,20 @@
+# Maintainer: Daniel Nagy <danielnagy at gmx de>
+# Contributor: Tom Vincent <http://tlvince.com/contact/>
+
+pkgname=eclipse-ivyde
+pkgver=2.2.0.final
+_pkgver=${pkgver}-201311091524-RELEASE
+pkgrel=1
+pkgdesc="Eclipse plugin which integrates Apache Ivy's dependency management"
+url="https://ant.apache.org/ivy/ivyde/"
+arch=('any')
+license=('apache')
+depends=('eclipse' 'eclipse-ivyde-ivy')
+source=("http://mirrors.ukfast.co.uk/sites/ftp.apache.org/ant/ivyde/${pkgver}/apache-ivyde-${_pkgver}.tar.gz")
+md5sums=('7bed9c2bcf920e7e29735f62a78495c3')
+
+package() {
+ local dest=${pkgdir}/usr/share/eclipse/dropins/${pkgname/eclipse-}/eclipse
+ mkdir -p $dest
+ tar --directory $dest --strip-components=1 --wildcards -xzvf ${srcdir}/apache-ivyde-${_pkgver}.tar.gz "*.jar"
+}