summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD9
-rw-r--r--titan.profile2
3 files changed, 11 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d8507e0289a5..7ef0c23b6b65 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -10,7 +10,9 @@ pkgbase = titan-git
depends = openssl
depends = jdk7-openjdk
source = git+https://github.com/eclipse/titan.core
+ source = titan.profile
md5sums = SKIP
+ md5sums = ecccd5d48359f5f0bdd81c8cc036e806
pkgname = titan-git
diff --git a/PKGBUILD b/PKGBUILD
index cc8f31fc84be..4e75af87ee47 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,8 +9,10 @@ url="https://projects.eclipse.org/projects/tools.titan"
license=('eclipse')
groups=('devel')
depends=('openssl' 'jdk7-openjdk')
-source=(git+https://github.com/eclipse/titan.core)
-md5sums=('SKIP')
+source=(git+https://github.com/eclipse/titan.core
+ titan.profile)
+md5sums=('SKIP'
+ 'ecccd5d48359f5f0bdd81c8cc036e806')
pkgver() {
cd $_pkgname
@@ -34,4 +36,7 @@ package() {
HELPDIR=$pkgdir/usr/share/doc/titan/html \
DEMODIR=$pkgdir/usr/share/doc/titan/demo \
install
+
+ install -D $srcdir/titan.profile \
+ $pkgdir/etc/profile.d/titan.sh
}
diff --git a/titan.profile b/titan.profile
new file mode 100644
index 000000000000..2c41a730a09a
--- /dev/null
+++ b/titan.profile
@@ -0,0 +1,2 @@
+export TTCN3_DIR=/usr/ttcn3
+export PATH=$PATH:$TTCN3_DIR/bin