summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD17
2 files changed, 15 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f5032dde3ede..00a6001231d1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,15 @@
# Generated by mksrcinfo v8
-# Mon Jan 11 03:06:43 UTC 2016
+# Sat Jun 25 15:33:54 UTC 2016
pkgbase = eclipse-umlet
pkgdesc = Simple UML drawing tool (Eclipse plugin version)
- pkgver = 13.3
+ pkgver = 14.2
pkgrel = 1
url = http://www.umlet.com
arch = any
license = GPL
depends = eclipse
- noextract = com.umlet.plugin_13.3.0.jar
- source = http://umlet.com/umlet_13_3/com.umlet.plugin_13.3.0.jar
- md5sums = 0142e45a46ef6634adf07790bf94f540
+ source = http://umlet.com/umlet_14_2/com.umlet.plugin-14.2.zip
+ sha256sums = 8ccfa18d4ab8bbb1a9a66bdbaef50c34bcd8b7c020269d51ff9b40c4385df44c
pkgname = eclipse-umlet
diff --git a/PKGBUILD b/PKGBUILD
index b88094f9232c..6b7634cab896 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,12 @@
+# Maintainer=rafaelsoaresbr <rafaelsoaresbr@gmail.com>
+# eclipse-umlet
+# Contributing: https://github.com/rafaelsoaresbr/pkgbuild
+# Builds: https://gitlab.com/rafaelsoaresbr/pkgbuild/builds
+
#Contributor blueray
-#Maintainer kaptoxic
+#Contributor kaptoxic
-pkgver=13.3
+pkgver=14.2
pkgname=eclipse-umlet
pkgrel=1
pkgdesc="Simple UML drawing tool (Eclipse plugin version)"
@@ -9,13 +14,13 @@ arch=('any')
url="http://www.umlet.com"
license=('GPL')
depends=('eclipse')
-source=("http://umlet.com/umlet_${pkgver//./_}/com.umlet.plugin_${pkgver}.0.jar")
-noextract=("com.umlet.plugin_${pkgver}.0.jar")
-md5sums=('0142e45a46ef6634adf07790bf94f540')
+source=("http://umlet.com/umlet_${pkgver//./_}/com.umlet.plugin-${pkgver}.zip")
+
+sha256sums=('8ccfa18d4ab8bbb1a9a66bdbaef50c34bcd8b7c020269d51ff9b40c4385df44c')
package() {
cd "$srcdir"
_dest="${pkgdir}/usr/share/eclipse"
install -d -m755 $_dest/plugins
- install -D -m644 com.umlet.plugin_${pkgver}.0.jar $_dest/plugins
+ install -D -m644 com.umlet.plugin-${pkgver}.jar $_dest/plugins
}