summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD35
2 files changed, 27 insertions, 21 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1a03f2a0f644..ca1491975c24 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,16 @@
pkgbase = ect
- pkgdesc = Efficient Compression Tool (or ECT) is a ++ file optimizer. It supports PNG, JPEG, GZIP and ZIP files.
- pkgver = 0.8.2
- pkgrel = 2
+ pkgdesc = file compressor, supports postcompression of PNG, JPEG, GZIP and ZIP files.
+ pkgver = 0.8.3
+ pkgrel = 1
url = https://github.com/fhanau/Efficient-Compression-Tool
arch = i686
arch = x86_64
- license = Apache2
+ license = Apache
makedepends = nasm
makedepends = git
- source = ect::git+https://github.com/fhanau/Efficient-Compression-Tool.git#tag=v0.8.2
- sha256sums = SKIP
+ depends = gcc-libs
+ source = git+https://github.com/fhanau/Efficient-Compression-Tool.git#commit=f0b38f7f8b750099f14d4976beff6a107d6119ac
+ md5sums = SKIP
pkgname = ect
diff --git a/PKGBUILD b/PKGBUILD
index 4ef8f64a2c41..b5711365fae9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,34 +1,39 @@
-#Maintainer: William J. Bowman <aur@williamjbowman.com>
+# Contributor: William J. Bowman <aur@williamjbowman.com>
+# Maintainer: Stefan Husmann <stefan-husmann@t-online.de>
pkgname=ect
-pkgver=0.8.2
-pkgrel=2
-pkgdesc='Efficient Compression Tool (or ECT) is a ++ file optimizer. It supports PNG, JPEG, GZIP and ZIP files.'
+_pkgname=Efficient-Compression-Tool
+pkgver=0.8.3
+pkgrel=1
+pkgdesc='file compressor, supports postcompression of PNG, JPEG, GZIP and ZIP files.'
url='https://github.com/fhanau/Efficient-Compression-Tool'
arch=('i686' 'x86_64')
-license=('Apache2')
-source=("ect::git+https://github.com/fhanau/Efficient-Compression-Tool.git#tag=v${pkgver}")
-sha256sums=('SKIP')
+license=('Apache')
+source=("git+https://github.com/fhanau/Efficient-Compression-Tool.git#commit=f0b38f7f8b750099f14d4976beff6a107d6119ac")
+md5sums=('SKIP')
+depends=('gcc-libs')
makedepends=('nasm' 'git')
-prepare(){
- cd "${srcdir}/${pkgname}/src"
+prepare() {
+ cd ${_pkgname}
+ git submodule init
git submodule update --init --recursive --recommend-shallow
- cd mozjpeg
- autoreconf -i
}
build() {
- cd "${srcdir}/${pkgname}/src"
+ cd ${_pkgname}
+ [ -d build ] || mkdir build
+ cd build
+ cmake -DECT_FOLDER_SUPPORT=off ../src
make
}
package() {
- cd "${srcdir}/${pkgname}/src"
+ cd ${_pkgname}/src
PREFIX=/usr/ DESTDIR="${pkgdir}" make install
- cd "${pkgdir}"/usr/bin
+ cd "${pkgdir}"/usr/bin
# Some things expect this to be an all-caps name
- ln -s ect ECT
+ ln -s ect ECT
}