summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD12
-rw-r--r--compile.patch12
3 files changed, 26 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b8188386a6f6..d16497eb742b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,9 @@
+# Generated by mksrcinfo v8
+# Mon Mar 13 11:59:03 UTC 2017
pkgbase = edb-debugger
pkgdesc = EDB (Evan's Debugger) is a QT4 based binary mode debugger with the goal of having usability on par with OllyDbg.
pkgver = 0.9.21
- pkgrel = 2
+ pkgrel = 3
url = http://www.codef00.com/projects#debugger
install = edb.install
arch = i686
@@ -15,12 +17,15 @@ pkgbase = edb-debugger
source = https://github.com/eteran/edb-debugger/releases/download/0.9.21/edb-debugger-0.9.21.tgz
source = edb.desktop
source = plugin_path.patch
+ source = compile.patch
md5sums = 3754a96538b8f881153d26e4bb96e423
md5sums = 8844cd95efef848f8f4a444259491961
md5sums = 76f3b5f5b51301d3334a93bdf54f3819
+ md5sums = bf3522695c8e00f1649f91ac3a64b064
sha256sums = 2686619e1288152033d4c9c9a2568cb12841d3854bba8815c37ce77d3bd11706
sha256sums = af1d0eae06544fbca7a9af2e2f55dc472324abf28402652e88d3b62c1882a132
sha256sums = 7f28fd5f37bc4493a48c199074ec4393b971246e8d208c28f4348d526ac60dce
+ sha256sums = dde1df3ab4c51513ff15c6eddbc63ff6fc8dddd8a51175b2f7911a2d0c8a237a
pkgname = edb-debugger
diff --git a/PKGBUILD b/PKGBUILD
index 0cfd726991e5..874186fe7a0e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=edb-debugger
pkgver=0.9.21
-pkgrel=2
+pkgrel=3
pkgdesc="EDB (Evan's Debugger) is a QT4 based binary mode debugger with the goal of having usability on par with OllyDbg."
arch=('i686' 'x86_64')
url='http://www.codef00.com/projects#debugger'
@@ -14,17 +14,21 @@ optdepends=('graphviz>=2.38.0')
install=edb.install
source=("https://github.com/eteran/edb-debugger/releases/download/$pkgver/edb-debugger-$pkgver.tgz"
'edb.desktop'
- 'plugin_path.patch')
+ 'plugin_path.patch'
+ 'compile.patch')
md5sums=('3754a96538b8f881153d26e4bb96e423'
'8844cd95efef848f8f4a444259491961'
- '76f3b5f5b51301d3334a93bdf54f3819')
+ '76f3b5f5b51301d3334a93bdf54f3819'
+ 'bf3522695c8e00f1649f91ac3a64b064')
sha256sums=('2686619e1288152033d4c9c9a2568cb12841d3854bba8815c37ce77d3bd11706'
'af1d0eae06544fbca7a9af2e2f55dc472324abf28402652e88d3b62c1882a132'
- '7f28fd5f37bc4493a48c199074ec4393b971246e8d208c28f4348d526ac60dce')
+ '7f28fd5f37bc4493a48c199074ec4393b971246e8d208c28f4348d526ac60dce'
+ 'dde1df3ab4c51513ff15c6eddbc63ff6fc8dddd8a51175b2f7911a2d0c8a237a')
prepare() {
cd "edb-debugger-$pkgver"
patch -p1 -i ../plugin_path.patch
+ patch -p1 -i ../compile.patch
}
build() {
diff --git a/compile.patch b/compile.patch
new file mode 100644
index 000000000000..25c6cd1adb49
--- /dev/null
+++ b/compile.patch
@@ -0,0 +1,12 @@
+diff -ruN 1/plugins/DebuggerCore/unix/linux/PlatformProcess.cpp 2/plugins/DebuggerCore/unix/linux/PlatformProcess.cpp
+--- 1/plugins/DebuggerCore/unix/linux/PlatformProcess.cpp 2017-03-13 11:40:51.106413430 +0100
++++ 2/plugins/DebuggerCore/unix/linux/PlatformProcess.cpp 2017-03-13 11:41:13.823536481 +0100
+@@ -364,7 +364,7 @@
+
+ while(in.status() == QTextStream::Ok) {
+ in >> ch;
+- if(ch == '\0') {
++ if(ch.isNull()) {
+ if(!s.isEmpty()) {
+ ret << s;
+ }