summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO20
-rw-r--r--BSD-2_clause26
-rw-r--r--PKGBUILD36
3 files changed, 82 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..da9860579ec0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = ee-editor
+ pkgdesc = EasyEdit, a classic curses text editor. Born in HP-UX, used in FreeBSD.
+ pkgver = 1.5.2
+ pkgrel = 3
+ url = http://www.users.qwest.net/~hmahon/
+ arch = i686
+ arch = x86_64
+ license = BSD
+ depends = ncurses
+ source = http://web.archive.org/web/20120716042037/http://mahon.cwx.net/sources/ee-1.5.2.src.tgz
+ source = BSD-2_clause
+ md5sums = 6e32713121f54cd021abf9b6e726a7b5
+ md5sums = 99184c6b857f9d2d49046d2b896f1692
+ sha1sums = da0697f34e407c010754922531b2f94bd7a589f8
+ sha1sums = 14719494c1780f00bd2017bfced9ad73e6f26639
+ sha256sums = e08d7511a48b43ee354042fe3fe7d9cb3431238caedcf4ac729c61a447003918
+ sha256sums = 5b2531f7c9363e2bc2212cc8e20f321793319bf564353b20a189b852a0e562cb
+
+pkgname = ee-editor
+
diff --git a/BSD-2_clause b/BSD-2_clause
new file mode 100644
index 000000000000..c12403038517
--- /dev/null
+++ b/BSD-2_clause
@@ -0,0 +1,26 @@
+Copyright (c) 2009, Hugh Mahon
+All rights reserved.
+
+Redistribution and use in source and binary forms, with or without
+modification, are permitted provided that the following conditions
+are met:
+
+ * Redistributions of source code must retain the above copyright
+ notice, this list of conditions and the following disclaimer.
+ * Redistributions in binary form must reproduce the above
+ copyright notice, this list of conditions and the following
+ disclaimer in the documentation and/or other materials provided
+ with the distribution.
+
+THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS
+"AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT
+LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS
+FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE
+COPYRIGHT OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT,
+INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING,
+BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES;
+LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER
+CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT
+LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN
+ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE
+POSSIBILITY OF SUCH DAMAGE.
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7cdea7c1c7fb
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: aksr <aksr at t-com dot me>
+pkgname=ee-editor
+_pkgname=ee
+pkgver=1.5.2
+pkgrel=3
+_realname='easyedit'
+pkgdesc='EasyEdit, a classic curses text editor. Born in HP-UX, used in FreeBSD.'
+arch=('i686' 'x86_64')
+url='http://www.users.qwest.net/~hmahon/'
+license=('BSD')
+depends=(ncurses)
+makedepends=()
+backup=()
+source=("http://web.archive.org/web/20120716042037/http://mahon.cwx.net/sources/$_pkgname-$pkgver.src.tgz"
+ 'BSD-2_clause')
+md5sums=('6e32713121f54cd021abf9b6e726a7b5'
+ '99184c6b857f9d2d49046d2b896f1692')
+sha1sums=('da0697f34e407c010754922531b2f94bd7a589f8'
+ '14719494c1780f00bd2017bfced9ad73e6f26639')
+sha256sums=('e08d7511a48b43ee354042fe3fe7d9cb3431238caedcf4ac729c61a447003918'
+ '5b2531f7c9363e2bc2212cc8e20f321793319bf564353b20a189b852a0e562cb')
+
+build() {
+ cd "$srcdir/$_realname-$pkgver"
+ ./create.make
+ make -f make.local curses
+}
+
+package() {
+ cd "$srcdir/$_realname-$pkgver"
+ mkdir -p $pkgdir/usr/{bin,share/{man/man1,licenses/$pkgname}}
+ install -sm755 ee $pkgdir/usr/bin
+ install -m755 ee.1 $pkgdir/usr/share/man/man1
+ install -m644 "$srcdir/BSD-2_clause" $pkgdir/usr/share/licenses/$pkgname/LICENSE
+}
+