summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD32
-rw-r--r--efmb.desktop9
-rw-r--r--efmb.pngbin0 -> 1046 bytes
4 files changed, 58 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..48620490876f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = efmb
+ pkgdesc = Endless Forms Most Beautiful is a crazy platformer with braincrashing mechanics
+ pkgver = 1.0
+ pkgrel = 2
+ url = http://www.locomalito.com/efmb.php
+ arch = x86_64
+ arch = i686
+ license = CCPL
+ source = http://www.locomalito.com/juegos/EFMB_linux.zip
+ source = efmb.png
+ source = efmb.desktop
+ md5sums = a286f67fab9d7ce041e5ce19fb71c40f
+ md5sums = 70f0c70dc0d0263dbafcd747a9301ec5
+ md5sums = 99dce59d073c2496e6ae5604fef74ef4
+
+pkgname = efmb
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..64621cffafff
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Alfonso Saaverda "Son Link" <sonlink.dourden@gmail.com>
+
+pkgname=efmb
+pkgver=1.0
+pkgrel=2
+pkgdesc="Endless Forms Most Beautiful is a crazy platformer with braincrashing mechanics"
+arch=('i686' 'x86_64')
+url=('http://www.locomalito.com/efmb.php')
+license=('CCPL')
+depends=()
+arch=('x86_64' 'i686')
+source=('http://www.locomalito.com/juegos/EFMB_linux.zip'
+ 'efmb.png' 'efmb.desktop')
+md5sums=('a286f67fab9d7ce041e5ce19fb71c40f'
+ '70f0c70dc0d0263dbafcd747a9301ec5'
+ '99dce59d073c2496e6ae5604fef74ef4')
+
+package() {
+ cd "${srcdir}/EFMB"
+ mkdir -p ${pkgdir}/usr/bin
+ echo "#!/bin/bash" > $pkgdir/usr/bin/$pkgname
+ echo "cd /opt/$pkgname/ && ./runner" >> $pkgdir/usr/bin/$pkgname
+ chmod 755 $pkgdir/usr/bin/$pkgname
+ mkdir -p ${pkgdir}/opt/${pkgname}
+ cp * -r ${pkgdir}/opt/${pkgname}
+ chmod -R 655 ${pkgdir}/opt/${pkgname}/runner
+ mkdir -p ${pkgdir}/usr/share/icons
+ mkdir -p ${pkgdir}/usr/share/applications/
+ install -m 644 "${srcdir}/efmb.png" ${pkgdir}/usr/share/icons
+ install -m 644 "${srcdir}/efmb.desktop" ${pkgdir}/usr/share/applications
+}
+
diff --git a/efmb.desktop b/efmb.desktop
new file mode 100644
index 000000000000..0f37692e89c0
--- /dev/null
+++ b/efmb.desktop
@@ -0,0 +1,9 @@
+[Desktop Entry]
+Version=1.0
+Name=Endless Forms Most Beautiful
+Comment=A crazy platformer with braincrashing mechanics
+Exec=efmb
+Icon=efmb
+Terminal=false
+Type=Application
+Categories=Game;
diff --git a/efmb.png b/efmb.png
new file mode 100644
index 000000000000..c0e40a780a70
--- /dev/null
+++ b/efmb.png
Binary files differ