summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD10
-rw-r--r--utf8.patch36
3 files changed, 48 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 82fc8a684714..9929249eee01 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,9 @@
+# Generated by mksrcinfo v8
+# Sun Oct 23 11:50:27 UTC 2016
pkgbase = eggdrop
pkgdesc = The world's most popular Open Source IRC bot.
pkgver = 1.6.21
- pkgrel = 5
+ pkgrel = 7
url = http://www.eggheads.org/
arch = i686
arch = x86_64
@@ -13,8 +15,10 @@ pkgbase = eggdrop
backup = etc/eggdrop.conf
source = http://ftp.eggheads.org/pub/eggdrop/source/1.6/eggdrop1.6.21.tar.bz2
source = dlopen.c
+ source = utf8.patch
sha256sums = 75bd5573a609eac3940c0b6ca8251c3f38ea5d54b520e1cad93c650b4bc21754
sha256sums = d1758f84a69173a852e598fa55e69df0d73b8b62c6993b0ba04aa21d539213e6
+ sha256sums = cdf0b1d59bbfa3f2c5937d96b57d55836af5ad36280351c6f1421d109ad693b3
pkgname = eggdrop
diff --git a/PKGBUILD b/PKGBUILD
index e4f731f4631c..58469f82096e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,21 +1,24 @@
+# Maintainer: kreon <kreon@jnode.in>
# Maintainer: Boohbah <boohbah at gmail.com>
# Contributor: Daniel J Griffiths <ghost1227 at archlinux.us>
# Contributor: Mantas Mikulėnas <grawity at gmail.com>
pkgname=eggdrop
pkgver=1.6.21
-pkgrel=5
+pkgrel=7
pkgdesc="The world's most popular Open Source IRC bot."
arch=('i686' 'x86_64')
url="http://www.eggheads.org/"
license=('GPL2')
depends=('sh' 'tcl>=8.3' 'zlib')
source=("http://ftp.eggheads.org/pub/$pkgname/source/1.6/$pkgname$pkgver.tar.bz2"
- 'dlopen.c')
+ 'dlopen.c' 'utf8.patch')
backup=("etc/$pkgname.conf")
options=('!makeflags')
sha256sums=('75bd5573a609eac3940c0b6ca8251c3f38ea5d54b520e1cad93c650b4bc21754'
- 'd1758f84a69173a852e598fa55e69df0d73b8b62c6993b0ba04aa21d539213e6')
+ 'd1758f84a69173a852e598fa55e69df0d73b8b62c6993b0ba04aa21d539213e6'
+ 'cdf0b1d59bbfa3f2c5937d96b57d55836af5ad36280351c6f1421d109ad693b3')
+
# Want multiple *unique* installations? Change the pkgname, it will just work.
_sharedir="/usr/share"
@@ -28,6 +31,7 @@ readonly -a _sharedir _modulesdir _scriptsdir _helpdir _bin _mandir
build() {
cd "$srcdir/$pkgname$pkgver"
+ patch -p1 < "$srcdir/utf8.patch"
# Don't complain about language files on startup.
sed -i "s|\"./language\"|\"$_sharedir/$pkgname/language\"|g" src/eggdrop.h
diff --git a/utf8.patch b/utf8.patch
new file mode 100644
index 000000000000..4d6025e5a8c2
--- /dev/null
+++ b/utf8.patch
@@ -0,0 +1,36 @@
+diff -Nura e2/src/eggdrop.h e1/src/eggdrop.h
+--- e2/src/eggdrop.h 2011-07-09 19:07:48.000000000 +0400
++++ e1/src/eggdrop.h 2016-10-08 01:24:41.533290748 +0300
+@@ -49,7 +49,7 @@
+ * You should leave this at 32 characters and modify nick-len in the
+ * configuration file instead.
+ */
+-#define HANDLEN 9 /* valid values 9->NICKMAX */
++#define HANDLEN 32 /* valid values 9->NICKMAX */
+ #define NICKMAX 32 /* valid values HANDLEN->32 */
+
+
+diff -Nura e2/src/main.h e1/src/main.h
+--- e2/src/main.h 2011-07-09 19:07:48.000000000 +0400
++++ e1/src/main.h 2016-10-08 01:25:20.746877377 +0300
+@@ -44,7 +44,7 @@
+ #endif
+
+ #if (((TCL_MAJOR_VERSION == 8) && (TCL_MINOR_VERSION >= 1)) || (TCL_MAJOR_VERSION > 8))
+-# define USE_TCL_BYTE_ARRAYS
++# undef USE_TCL_BYTE_ARRAYS
+ # define USE_TCL_ENCODING
+ #endif
+
+diff -Nura e2/src/tcl.c e1/src/tcl.c
+--- e2/src/tcl.c 2011-09-10 01:37:53.000000000 +0400
++++ e1/src/tcl.c 2016-10-08 01:25:00.830082096 +0300
+@@ -863,7 +863,7 @@
+ }
+
+ if (encoding == NULL) {
+- encoding = "iso8859-1";
++ encoding = "utf-8";
+ }
+
+ Tcl_SetSystemEncoding(NULL, encoding);