summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD12
2 files changed, 12 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6abc3a28d721..66091cb708a4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = egl-wayland-git
pkgdesc = EGLStream-based Wayland external platform (git version)
- pkgver = 1.0.3.r18.g0eb29d4
+ pkgver = 1.1.0.r1.g0eb29d4
pkgrel = 1
url = https://github.com/NVIDIA/egl-wayland/
arch = i686
diff --git a/PKGBUILD b/PKGBUILD
index 5f471c260521..637515499cdf 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: Det
pkgname=egl-wayland-git
-pkgver=1.0.3.r18.g0eb29d4
+pkgver=1.1.0.r1.g0eb29d4
pkgrel=1
pkgdesc='EGLStream-based Wayland external platform (git version)'
arch=('i686' 'x86_64')
@@ -17,6 +17,16 @@ source=("$pkgname"::'git+https://github.com/NVIDIA/egl-wayland.git'
sha256sums=('SKIP'
'5cccf1905a266e8e34d5ad4aad4be85390e60b1a0850a29dd9d64adc641de412')
+prepare() {
+ cd "$pkgname"
+
+ # add missing upstream tag
+ # https://github.com/NVIDIA/egl-wayland/commit/1676d1d2bfe646fb3ecbba29a85db529dd399493
+ local _tag
+ _tag="$(git tag -l 1.1.0)"
+ [ "$_tag" != '1.1.0' ] && git tag 1.1.0 1676d1d2bfe646fb3ecbba29a85db529dd399493
+}
+
pkgver() {
cd "$pkgname"