summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO25
-rw-r--r--PKGBUILD57
-rw-r--r--egoboo.desktop7
-rw-r--r--egoboo.pngbin0 -> 956 bytes
4 files changed, 89 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0a157a15c4ed
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,25 @@
+pkgbase = egoboo-git
+ pkgdesc = An action RPG/dungeon crawling adventure with OpenGL 3D graphics (development version)
+ pkgver = 2.8.1.r1367.873a0a9
+ pkgrel = 1
+ url = http://egoboo.sourceforge.net/
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = mesa
+ depends = sdl_image
+ depends = sdl_mixer
+ depends = sdl_ttf
+ depends = physfs
+ depends = enet
+ depends = libgl
+ depends = glu
+ source = git+https://github.com/egoboo/egoboo.git
+ source = egoboo.png
+ source = egoboo.desktop
+ sha256sums = SKIP
+ sha256sums = 7b112e3449b1881c9a218959817b6db9c23c393910ed9a2856b5fc9e8cf267a8
+ sha256sums = ee96f15b9edacf9d6ee12e0be0ad324e48a80002597b5520e9e9edf757b150ca
+
+pkgname = egoboo-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9b9e3f4e9b94
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,57 @@
+# Maintainer: carstene1ns <arch carsten-teibes de> - http://git.io/ctPKG
+
+pkgname=egoboo-git
+pkgver=2.8.1.r1367.873a0a9
+pkgrel=1
+arch=('i686' 'x86_64')
+license=('GPL')
+pkgdesc="An action RPG/dungeon crawling adventure with OpenGL 3D graphics (development version)"
+url="http://egoboo.sourceforge.net/"
+depends=('sdl_image' 'sdl_mixer' 'sdl_ttf' 'physfs' 'enet' 'libgl' 'glu')
+makedepends=('mesa')
+source=("git+https://github.com/egoboo/egoboo.git"
+ "egoboo.png"
+ "egoboo.desktop")
+sha256sums=('SKIP'
+ '7b112e3449b1881c9a218959817b6db9c23c393910ed9a2856b5fc9e8cf267a8'
+ 'ee96f15b9edacf9d6ee12e0be0ad324e48a80002597b5520e9e9edf757b150ca')
+
+pkgver() {
+ cd egoboo
+ # needs to be updated later, when the repo has proper tags
+ printf "2.8.1.r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ cd egoboo
+
+ # adapt paths
+ sed 's|egoboo-2.x|egoboo|g;s|share/games/|share/|g;s|etc/|share/|g;s|games/|bin/|g' \
+ -i egolib/src/egolib/platform/file_linux.c
+ # allow adding our flags
+ sed 's|CFLAGS :=|CFLAGS +=|;s|CXXFLAGS:=|CXXFLAGS+=|' -i egolib/Makefile game/Makefile
+ # fix linking
+ sed 's|-lenet|-lenet -lm -lstdc++|' -i game/Makefile
+}
+
+build() {
+ make -C egoboo
+}
+
+package() {
+ cd egoboo
+ # doc
+ install -d "$pkgdir"/usr/share/doc
+ cp -rup doc "$pkgdir"/usr/share/doc/egoboo
+ # binary
+ cd game
+ install -Dm755 egoboo-2.x "$pkgdir"/usr/bin/egoboo
+ # data
+ cd data
+ install -d "$pkgdir"/usr/share/egoboo
+ cp -rup *.txt basicdat modules "$pkgdir"/usr/share/egoboo
+ find "$pkgdir"/usr/share/egoboo -type f -print0 | xargs -0 chmod 644
+ # icon and .desktop file
+ install -Dm644 "$srcdir"/egoboo.png "$pkgdir"/usr/share/pixmaps/egoboo.png
+ install -Dm644 "$srcdir"/egoboo.desktop "$pkgdir"/usr/share/applications/egoboo.desktop
+}
diff --git a/egoboo.desktop b/egoboo.desktop
new file mode 100644
index 000000000000..e33bde525376
--- /dev/null
+++ b/egoboo.desktop
@@ -0,0 +1,7 @@
+[Desktop Entry]
+Type=Application
+Name=Egoboo
+Exec=egoboo
+Icon=egoboo
+Comment=A 3D OpenGL dungeon-crawl
+Categories=Game;AdventureGame;RolePlaying;
diff --git a/egoboo.png b/egoboo.png
new file mode 100644
index 000000000000..984be247da3b
--- /dev/null
+++ b/egoboo.png
Binary files differ