summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO20
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD14
-rw-r--r--esee.patch35
4 files changed, 12 insertions, 58 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3e8b84a9bc7f..d576e56da772 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Tue Oct 10 21:10:16 UTC 2017
+# Mon Feb 26 17:31:28 UTC 2018
pkgbase = eiskaltdcpp-git
pkgdesc = EiskaltDC++: DC and ADC client based on dcpp core. (GIT Version)
- pkgver = 2.2.10.180.g4c9cbf20
+ pkgver = 2.2.10.186.g1c0173ec
pkgrel = 1
url = https://github.com/eiskaltdcpp/eiskaltdcpp
arch = i686
@@ -34,9 +34,7 @@ pkgbase = eiskaltdcpp-git
conflicts = eiskaltdcpp
options = !emptydirs
source = git+https://github.com/eiskaltdcpp/eiskaltdcpp.git
- source = esee.patch
sha256sums = SKIP
- sha256sums = b68a4def7204214d418efabfe130393e6b8481a3b348defeb9050bbb2693fa54
pkgname = eiskaltdcpp-core-git
pkgdesc = EiskaltDC++ Core. (GIT Version)
@@ -47,13 +45,13 @@ pkgname = eiskaltdcpp-core-git
depends = boost-libs
depends = miniupnpc
depends = pcre
- provides = eiskaltdcpp-core=2.2.10.180.g4c9cbf20
+ provides = eiskaltdcpp-core=2.2.10.186.g1c0173ec
conflicts = eiskaltdcpp-core
pkgname = eiskaltdcpp-qt-git
pkgdesc = Qt5-based DC and ADC client for EiskaltDC++ core. (GIT Version)
- depends = eiskaltdcpp-core-git=2.2.10.180.g4c9cbf20
- depends = eiskaltdcpp-data-git=2.2.10.180.g4c9cbf20
+ depends = eiskaltdcpp-core-git=2.2.10.186.g1c0173ec
+ depends = eiskaltdcpp-data-git=2.2.10.186.g1c0173ec
depends = aspell
depends = qt5-multimedia
depends = qt5-quick1
@@ -66,8 +64,8 @@ pkgname = eiskaltdcpp-qt-git
pkgname = eiskaltdcpp-gtk-git
pkgdesc = Gtk-based DC and ADC client for EiskaltDC++ core. (GIT Version)
- depends = eiskaltdcpp-core-git=2.2.10.180.g4c9cbf20
- depends = eiskaltdcpp-data-git=2.2.10.180.g4c9cbf20
+ depends = eiskaltdcpp-core-git=2.2.10.186.g1c0173ec
+ depends = eiskaltdcpp-data-git=2.2.10.186.g1c0173ec
depends = gtk3
depends = libnotify
provides = eiskaltdcpp-gtk
@@ -77,7 +75,7 @@ pkgname = eiskaltdcpp-gtk-git
pkgname = eiskaltdcpp-daemon-git
pkgdesc = DC and ADC daemon for EiskaltDC++ core. (GIT Version)
- depends = eiskaltdcpp-core-git=2.2.10.180.g4c9cbf20
+ depends = eiskaltdcpp-core-git=2.2.10.186.g1c0173ec
depends = jsoncpp
provides = eiskaltdcpp-daemon
conflicts = eiskaltdcpp-daemon
@@ -85,7 +83,7 @@ pkgname = eiskaltdcpp-daemon-git
pkgname = eiskaltdcpp-cli-git
pkgdesc = CLI interface for EiskaltDC++ Daemon. (GIT Version)
arch = any
- depends = eiskaltdcpp-daemon-git=2.2.10.180.g4c9cbf20
+ depends = eiskaltdcpp-daemon-git=2.2.10.186.g1c0173ec
depends = perl-json
depends = perl-json-rpc
provides = eiskaltdcpp-cli
diff --git a/.gitignore b/.gitignore
index 300a542d8569..05c6d4d4c97b 100644
--- a/.gitignore
+++ b/.gitignore
@@ -2,4 +2,3 @@
!.gitignore
!.SRCINFO
!PKGBUILD
-!esee.patch
diff --git a/PKGBUILD b/PKGBUILD
index f5e2219eb396..e7024769c287 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,7 +9,7 @@ pkgname=('eiskaltdcpp-core-git'
'eiskaltdcpp-cli-git'
'eiskaltdcpp-data-git'
)
-pkgver=2.2.10.180.g4c9cbf20
+pkgver=2.2.10.186.g1c0173ec
pkgrel=1
pkgdesc="EiskaltDC++: DC and ADC client based on dcpp core. (GIT Version)"
license=('GPL3')
@@ -17,12 +17,8 @@ arch=('i686' 'x86_64' 'arm' 'armv7h' 'armv6h')
url='https://github.com/eiskaltdcpp/eiskaltdcpp'
conflicts=('eiskaltdcpp')
options=('!emptydirs')
-source=('git+https://github.com/eiskaltdcpp/eiskaltdcpp.git'
- 'esee.patch'
- )
-sha256sums=('SKIP'
- 'b68a4def7204214d418efabfe130393e6b8481a3b348defeb9050bbb2693fa54'
- )
+source=('git+https://github.com/eiskaltdcpp/eiskaltdcpp.git')
+sha256sums=('SKIP')
makedepends=('git'
'cmake'
'lua'
@@ -57,10 +53,6 @@ prepare() {
# Fix php dependency
find . -type f -name '*.php' -exec sed 's|php5|php|g' -i '{}' \;
-
- cd eiskaltdcpp
- # Bleh patch for set right version
- patch -p1 -i "${srcdir}/esee.patch"
}
build() {
diff --git a/esee.patch b/esee.patch
deleted file mode 100644
index 6dbbbf7f1184..000000000000
--- a/esee.patch
+++ /dev/null
@@ -1,35 +0,0 @@
-diff --git a/CMakeLists.txt b/CMakeLists.txt
-index 034eb27e..25334cb7 100644
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -241,19 +241,17 @@ endif (APPLE)
-
- message (STATUS "Data directory: ${CLIENT_DATA_DIR}")
-
--if (DCPP_REVISION)
-- set (VERSION_SUFFIX ${DCPP_REVISION})
-- set (VERSION "${VERSION}-${VERSION_SUFFIX}")
-- message (STATUS "DCPP_REVISION is set to: ${VERSION_SUFFIX}")
-- message (STATUS "Current VERSION: ${VERSION}")
--elseif (GIT_FOUND)
-- execute_process (COMMAND ${GIT_EXECUTABLE} describe --tags
-- WORKING_DIRECTORY ${PROJECT_SOURCE_DIR}
-- OUTPUT_VARIABLE VERSION
-- OUTPUT_STRIP_TRAILING_WHITESPACE)
-- string (REGEX REPLACE "^v" "" VERSION "${VERSION}")
-- message (STATUS "Build Git snapshot: ${VERSION}")
--endif ()
-+if (GIT_FOUND)
-+ execute_process (COMMAND ${GIT_EXECUTABLE} describe --tags
-+ WORKING_DIRECTORY ${PROJECT_SOURCE_DIR}
-+ OUTPUT_VARIABLE VERSION
-+ OUTPUT_STRIP_TRAILING_WHITESPACE)
-+ string (REGEX REPLACE "^v" "" VERSION "${VERSION}")
-+ message (STATUS "Build Git snapshot: ${VERSION}")
-+else (GIT_FOUND)
-+ set (VERSION "${VERSION}")
-+ message (STATUS "Current VERSION: ${VERSION}")
-+endif (GIT_FOUND)
-
- configure_file(${PROJECT_SOURCE_DIR}/Version.h.in ${PROJECT_BINARY_DIR}/VersionGlobal.h)
-