summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD24
2 files changed, 20 insertions, 23 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fc6291e0d915..1883ef45c6f0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Wed Apr 11 19:14:49 UTC 2018
+# Fri Oct 19 23:10:06 UTC 2018
pkgbase = eiskaltdcpp-git
pkgdesc = EiskaltDC++: DC and ADC client based on dcpp core. (GIT Version)
- pkgver = 2.2.10.188.g1e72256a
+ pkgver = v2.2.10.275.gc4936c5a
pkgrel = 1
url = https://github.com/eiskaltdcpp/eiskaltdcpp
arch = x86_64
@@ -41,13 +41,14 @@ pkgname = eiskaltdcpp-core-git
depends = boost-libs
depends = miniupnpc
depends = pcre
- provides = eiskaltdcpp-core=2.2.10.188.g1e72256a
+ provides = eiskaltdcpp-core=v2.2.10.275.gc4936c5a
+ provides = eiskaltdcpp-git
conflicts = eiskaltdcpp-core
pkgname = eiskaltdcpp-qt-git
pkgdesc = Qt5-based DC and ADC client for EiskaltDC++ core. (GIT Version)
- depends = eiskaltdcpp-core-git=2.2.10.188.g1e72256a
- depends = eiskaltdcpp-data-git=2.2.10.188.g1e72256a
+ depends = eiskaltdcpp-core-git=v2.2.10.275.gc4936c5a
+ depends = eiskaltdcpp-data-git=v2.2.10.275.gc4936c5a
depends = aspell
depends = qt5-multimedia
depends = qt5-quick1
@@ -60,8 +61,8 @@ pkgname = eiskaltdcpp-qt-git
pkgname = eiskaltdcpp-gtk-git
pkgdesc = Gtk-based DC and ADC client for EiskaltDC++ core. (GIT Version)
- depends = eiskaltdcpp-core-git=2.2.10.188.g1e72256a
- depends = eiskaltdcpp-data-git=2.2.10.188.g1e72256a
+ depends = eiskaltdcpp-core-git=v2.2.10.275.gc4936c5a
+ depends = eiskaltdcpp-data-git=v2.2.10.275.gc4936c5a
depends = gtk3
depends = libnotify
provides = eiskaltdcpp-gtk
@@ -71,7 +72,7 @@ pkgname = eiskaltdcpp-gtk-git
pkgname = eiskaltdcpp-daemon-git
pkgdesc = DC and ADC daemon for EiskaltDC++ core. (GIT Version)
- depends = eiskaltdcpp-core-git=2.2.10.188.g1e72256a
+ depends = eiskaltdcpp-core-git=v2.2.10.275.gc4936c5a
depends = jsoncpp
provides = eiskaltdcpp-daemon
conflicts = eiskaltdcpp-daemon
@@ -79,7 +80,7 @@ pkgname = eiskaltdcpp-daemon-git
pkgname = eiskaltdcpp-cli-git
pkgdesc = CLI interface for EiskaltDC++ Daemon. (GIT Version)
arch = any
- depends = eiskaltdcpp-daemon-git=2.2.10.188.g1e72256a
+ depends = eiskaltdcpp-daemon-git=v2.2.10.275.gc4936c5a
depends = perl-json
depends = perl-json-rpc
provides = eiskaltdcpp-cli
diff --git a/PKGBUILD b/PKGBUILD
index 9aadf2a68b96..a4cdde52bb52 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,7 +9,7 @@ pkgname=('eiskaltdcpp-core-git'
'eiskaltdcpp-cli-git'
'eiskaltdcpp-data-git'
)
-pkgver=2.2.10.188.g1e72256a
+pkgver=v2.2.10.275.gc4936c5a
pkgrel=1
pkgdesc="EiskaltDC++: DC and ADC client based on dcpp core. (GIT Version)"
license=('GPL3')
@@ -45,7 +45,7 @@ makedepends=('git'
pkgver() {
cd eiskaltdcpp
- echo "$(git describe --long --tags | tr - . | tr -d v)"
+ echo "$(git describe --long --tags | tr - .)"
}
prepare() {
@@ -53,12 +53,10 @@ prepare() {
# Fix php dependency
find . -type f -name '*.php' -exec sed 's|php5|php|g' -i '{}' \;
-}
-
-build() {
- cd "${srcdir}/build"
+ cd build
cmake ../eiskaltdcpp \
+ -DCMAKE_BUILD_TYPE=None \
-DCMAKE_INSTALL_PREFIX=/usr \
-DUSE_QT5=ON \
-DUSE_QT_QML=ON \
@@ -81,13 +79,14 @@ build() {
-DUSE_CLI_JSONRPC=ON \
-DLOCAL_JSONCPP=OFF \
-DLOCAL_BOOST=OFF
+}
- make
+build() {
+ make -C build
}
package_eiskaltdcpp-core-git() {
pkgdesc="EiskaltDC++ Core. (GIT Version)"
- pkgver="$(cd eiskaltdcpp; echo "$(git describe --long --tags | tr - . | tr -d v)")"
depends=('openssl'
'lua'
'libidn'
@@ -96,7 +95,9 @@ package_eiskaltdcpp-core-git() {
'miniupnpc'
'pcre'
)
- provides=("eiskaltdcpp-core=${pkgver}")
+ provides=("eiskaltdcpp-core=${pkgver}"
+ 'eiskaltdcpp-git'
+ )
conflicts=('eiskaltdcpp-core')
opdepends=('eiskaltdcpp-qt-git: EiskaltDC++ Qt interface'
'eiskaltdcpp-gtk-git: EiskaltDC++ GTK interface'
@@ -109,7 +110,6 @@ package_eiskaltdcpp-core-git() {
package_eiskaltdcpp-qt-git() {
pkgdesc="Qt5-based DC and ADC client for EiskaltDC++ core. (GIT Version)"
- pkgver="$(cd eiskaltdcpp; echo "$(git describe --long --tags | tr - . | tr -d v)")"
depends=("eiskaltdcpp-core-git=${pkgver}"
"eiskaltdcpp-data-git=${pkgver}"
'aspell'
@@ -129,7 +129,6 @@ package_eiskaltdcpp-qt-git() {
package_eiskaltdcpp-gtk-git() {
pkgdesc="Gtk-based DC and ADC client for EiskaltDC++ core. (GIT Version)"
- pkgver="$(cd eiskaltdcpp; echo "$(git describe --long --tags | tr - . | tr -d v)")"
depends=("eiskaltdcpp-core-git=${pkgver}"
"eiskaltdcpp-data-git=${pkgver}"
'gtk3'
@@ -146,7 +145,6 @@ package_eiskaltdcpp-gtk-git() {
package_eiskaltdcpp-daemon-git() {
pkgdesc="DC and ADC daemon for EiskaltDC++ core. (GIT Version)"
- pkgver="$(cd eiskaltdcpp; echo "$(git describe --long --tags | tr - . | tr -d v)")"
depends=("eiskaltdcpp-core-git=${pkgver}"
'jsoncpp'
)
@@ -159,7 +157,6 @@ package_eiskaltdcpp-daemon-git() {
package_eiskaltdcpp-cli-git() {
arch=('any')
pkgdesc="CLI interface for EiskaltDC++ Daemon. (GIT Version)"
- pkgver="$(cd eiskaltdcpp; echo "$(git describe --long --tags | tr - . | tr -d v)")"
depends=("eiskaltdcpp-daemon-git=${pkgver}"
'perl-json'
'perl-json-rpc'
@@ -175,7 +172,6 @@ package_eiskaltdcpp-cli-git() {
package_eiskaltdcpp-data-git() {
arch=('any')
pkgdesc="EiskaltDC++ common data files. (GIT Version)"
- pkgver="$(cd eiskaltdcpp; echo "$(git describe --long --tags | tr - . | tr -d v)")"
depends=('bash'
'hicolor-icon-theme'
)