summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD41
-rwxr-xr-xcheckver.py18
3 files changed, 72 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9b8ffd8b176e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = ekopath-bin
+ pkgdesc = A high-performance Intel 64 / AMD64 compiler for C99, C++ 2003, Fortran 90/95 and partial 2003
+ pkgver = 20160212
+ pkgrel = 1
+ url = http://pathscale.com/ekopath-compiler-suite
+ arch = x86_64
+ license = GPL
+ options = !strip
+ source = checkver.py
+ md5sums = dee1655664ef4a5fe3d05b0b5aff00ac
+
+pkgname = ekopath-bin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..32804d28b8dc
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+# Maintainer: kfgz <kfgz at interia dot pl>
+# Contributor: 6xx
+# Contributor: csslayer
+
+pkgname=ekopath-bin
+_real_name=ekopath
+pkgver=20160212
+pkgrel=1
+pkgdesc="A high-performance Intel 64 / AMD64 compiler for C99, C++ 2003, Fortran 90/95 and partial 2003"
+url="http://pathscale.com/ekopath-compiler-suite"
+arch=('x86_64')
+license=('GPL')
+options=(!strip)
+source=(checkver.py)
+
+pkgver() {
+ date +%Y%m%d
+}
+
+build() {
+export DLURL=$(${srcdir}/checkver.py)
+export DLFILENAME=${DLURL##*/}
+
+ msg "Downloading $DLFILENAME"
+
+ if [ ! -f ${DLFILENAME} ]; then
+ wget ${DLURL}
+ fi
+ chmod +x ${DLFILENAME}
+}
+
+package() {
+ "$srcdir/$DLFILENAME" --mode unattended --prefix "${pkgdir}"/usr
+
+ rm -f "${pkgdir}"/usr/uninstall
+ rm -f "${pkgdir}"/usr/bin/{pathdb,funclookup}
+ chmod +x "${pkgdir}"/usr/bin/pathcc
+ rm -f "${pkgdir}"/usr/bin/pathcc.bak
+
+}
+md5sums=('dee1655664ef4a5fe3d05b0b5aff00ac')
diff --git a/checkver.py b/checkver.py
new file mode 100755
index 000000000000..e7fe770fa1af
--- /dev/null
+++ b/checkver.py
@@ -0,0 +1,18 @@
+#!/usr/bin/env python3
+import http.client,datetime
+
+tempdate = datetime.date.today()
+timedelta = datetime.timedelta(days=1)
+url = "c591116.r16.cf2.rackcdn.com"
+requrl = "/ekopath/nightly/Linux/"
+
+while(True):
+ conn = http.client.HTTPConnection(url)
+ filename = "ekopath-" + tempdate.strftime("%Y-%m-%d") + "-installer.run"
+ req = conn.request("HEAD", requrl + filename)
+ resp = conn.getresponse()
+ conn.close()
+ if resp.status == 200:
+ print("http://" + url + requrl + filename)
+ break
+ tempdate -= timedelta