summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD24
-rw-r--r--electron-cash-git.install23
-rw-r--r--electron-cash.install16
4 files changed, 36 insertions, 29 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 54b380135687..32cfbc0aad36 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -3,7 +3,7 @@ pkgbase = electron-cash-git
pkgver = 2.9.2.r5.g8b2bdb6b
pkgrel = 1
url = http://www.electroncash.org/
- install = electron-cash.install
+ install = electron-cash-git.install
arch = any
license = MIT
makedepends = git
diff --git a/PKGBUILD b/PKGBUILD
index 1862e8936a83..9a386e907498 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,11 +9,19 @@
#
pkgname=electron-cash-git
+pkgdesc="Lightweight Bitcoin Cash wallet"
pkgver=2.9.2.r5.g8b2bdb6b
pkgrel=1
-pkgdesc="Lightweight Bitcoin Cash wallet"
url='http://www.electroncash.org/'
+install="${pkgname}.install"
arch=('any')
+license=('MIT')
+makedepends=(
+ 'git'
+ 'protobuf'
+ 'python2-pycurl'
+ 'python2-setuptools'
+)
depends=(
'hicolor-icon-theme'
'python2'
@@ -29,12 +37,6 @@ depends=(
'python2-requests'
'python2-six'
'qt4')
-makedepends=(
- 'git'
- 'protobuf'
- 'python2-pycurl'
- 'python2-setuptools'
-)
optdepends=(
'desktop-file-utils: update desktop icon'
'gtk-update-icon-cache: update desktop icon'
@@ -48,12 +50,10 @@ optdepends=(
'xdg-utils: update desktop icon'
'zbar: QR code reading support'
)
-license=('MIT')
-provides=('electron-cash')
-conflicts=('electron-cash')
+provides=("${pkgname/-git/}")
+conflicts=("${pkgname/-git/}")
source=('electron-cash::git+https://github.com/fyookball/electrum.git')
sha256sums=('SKIP')
-install=electron-cash.install
pkgver() {
cd "${pkgname/-git/}"
@@ -82,7 +82,7 @@ package() {
cd ${pkgname/-git/}
msg2 'Installing...'
- python2 setup.py install --root="${pkgdir}" --optimize=1
+ python2 setup.py install --root="${pkgdir}"
msg2 'Cleaning up pkgdir...'
find "${pkgdir}" -type d -name .git -exec rm -r '{}' +
diff --git a/electron-cash-git.install b/electron-cash-git.install
new file mode 100644
index 000000000000..c14de3d340f8
--- /dev/null
+++ b/electron-cash-git.install
@@ -0,0 +1,23 @@
+post_install() {
+ if [[ -x /usr/bin/update-desktop-database ]]; then
+ update-desktop-database -q
+ fi
+
+ if [[ -x /usr/bin/xdg-icon-resource ]]; then
+ xdg-icon-resource forceupdate --theme hicolor
+ fi
+
+ if [[ -x /usr/bin/gtk-update-icon-cache ]]; then
+ gtk-update-icon-cache -f -q /usr/share/icons/hicolor
+ fi
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+}
+
+# vim: ts=2 sw=2 et:
diff --git a/electron-cash.install b/electron-cash.install
deleted file mode 100644
index b9649c46769a..000000000000
--- a/electron-cash.install
+++ /dev/null
@@ -1,16 +0,0 @@
-post_install() {
- ( [[ -x /usr/bin/update-desktop-database ]] && update-desktop-database -q ) \
- || true
- ( [[ -x /usr/bin/xdg-icon-resource ]] && xdg-icon-resource forceupdate --theme hicolor ) \
- || true
- ( [[ -x /usr/bin/gtk-update-icon-cache ]] && gtk-update-icon-cache -f -q /usr/share/icons/hicolor ) \
- || true
-}
-
-post_upgrade() {
- post_install
-}
-
-post_remove() {
- post_install
-}