summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--PKGBUILD15
-rw-r--r--electrumx.conf41
-rw-r--r--electrumx.service4
3 files changed, 32 insertions, 28 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 11c94914a11b..99489207ff64 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,9 @@
-# Maintainer: Andy Weidenbaum <archbaum@gmail.com>
+# Maintainer: Steven Malis <smmalis37@gmail.com>
+# Contributer: Andy Weidenbaum <archbaum@gmail.com>
pkgname=electrumx
-pkgver=1.0.11
-pkgrel=2
+pkgver=1.0.17
+pkgrel=1
pkgdesc="Server implementation for the Electrum wallet"
arch=('any')
depends=('leveldb'
@@ -11,7 +12,7 @@ depends=('leveldb'
'python-irc'
'python-plyvel'
'python-pylru')
-makedepends=('expect' 'openssl' 'python-setuptools')
+makedepends=('openssl' 'python-setuptools')
optdepends=('bitcoin-core: Bitcoin core headless P2P node'
'electrum: Bitcoin thin client')
url="https://github.com/kyuupichan/electrumx"
@@ -20,9 +21,9 @@ options=(!emptydirs)
source=($pkgname-$pkgver.tar.gz::https://codeload.github.com/kyuupichan/$pkgname/tar.gz/$pkgver
'electrumx.conf'
'electrumx.service')
-sha256sums=('9e43399daf42115d50299d578d19a2565645ce815c3bd9c3851d8b4e027e9256'
- '6134f8e333fc622bea781ed334b738ade39bf7a6e4ace3704cba2e22788a4bf3'
- 'a70e6d2ff4e0eb8125ba2d52bcdaec96129068363e365d48a47961f47b9fc554')
+sha256sums=('31ad831594cdc33087caf82903800c203a0ca440c58d555d7209775b14885616'
+ 'cf9b54e8841024fe10e35576514e8fc1de4be40e139f8dbc662ef149956f1d44'
+ 'b4e1a9d4341edf1f2022f8c8591d28ef6bd6db38c6f332445ac294b5fc6dae93')
backup=('etc/electrumx/electrumx.conf'
'usr/lib/systemd/system/electrumx.service')
install=electrumx.install
diff --git a/electrumx.conf b/electrumx.conf
index aa2134be9edb..559f1450a16c 100644
--- a/electrumx.conf
+++ b/electrumx.conf
@@ -4,26 +4,32 @@
#REQUIRED
#
+ #The folder to store the electrumx database
DB_DIRECTORY = /srv/electrumx
+
+ #The linux user to run the server under
USERNAME = electrumx
+
+ #The path to the electrumx binary
ELECTRUMX = /usr/bin/electrumx-server
#Bitcoin Node RPC Credentials
#assumes https://aur.archlinux.org/packages/bitcoin-core/bitcoin.conf
+ #port is optional, defaults to COIN RPC default
DAEMON_URL = http://bitcoin:secret@127.0.0.1:8332/
- #port is optional, defaults to COIN RPC default
#
#REQUIRED FOR PUBLIC VISIBILITY
#
+ #listen on interface and ports (0.0.0.0 is any)
HOST = 127.0.0.1
- #listen on interface, (0.0.0.0 is any)
TCP_PORT = 50001
SSL_PORT = 50002
- #Requires
- SSL_CERTFILE = /etc/electrumx/server.cert
- SSL_KEYFILE = /etc/electrumx/server.pem
+
+ #path to ssl cert and key for enabling ssl support
+ SSL_CERTFILE = /etc/electrumx/server.cert
+ SSL_KEYFILE = /etc/electrumx/server.pem
#
#OPTIONAL VISIBILITY
@@ -31,31 +37,28 @@
#BANNER_FILE = /path/to/banner
#DONATION_ADDRESS =
- #IRC = yes
- #IRC_NICK =
#REPORT_HOST = $HOST
#REPORT_TCP_PORT = #defaults to TCP_PORT
#REPORT_SSL_PORT = #defaults to SSL_PORT
- RPC_PORT = 8000
-
+ #RPC_PORT = 8000
#
#MISC
#
+ #lib/coins.py
COIN = Bitcoin
- #lib/coins.py
- NET = mainnet
- #lib/coins.py
+ NET = bitcoin-segwit
+
+ #leveldb or rocksdb (You'll need to install appropriate python packages)
DB_ENGINE = leveldb
- #leveldb, rocksdb (You'll need to install appropriate python packages)
+ #maximum number of blocks to be able to handle in a chain
+ #reorganisation. ElectrumX retains some fairly compact
+ #undo information for this many blocks in levelDB.
#REORG_LIMIT = 200
- #maximum number of blocks to be able to handle in a chain
- #reorganisation. ElectrumX retains some fairly compact
- #undo information for this many blocks in levelDB.
+ #Set to anything non-empty to remove IP addresses from logs.
ANON_LOGS = yes
- #Set to anything non-empty to remove IP addresses from logs.
#These following environment variables are to help limit server
@@ -64,7 +67,7 @@
#each and are processed efficiently. I feel the defaults are low and
#encourage you to raise them.
+ #Maximum number of address subscriptions across all sessions
MAX_SUBS = 250000
- #Maximum number of address subscriptions across all sessions
+ #Maximum number of address subscriptions permitted to a single session.
MAX_SESSION_SUBS = 50000
- #Maximum number of address subscriptions permitted to a single session.
diff --git a/electrumx.service b/electrumx.service
index f9efc5233c11..7881eb8653b5 100644
--- a/electrumx.service
+++ b/electrumx.service
@@ -1,7 +1,7 @@
[Unit]
Description=ElectrumX Server
-Wants=bitcoin.service
-After=network.target bitcoin.service
+Wants=bitcoind.service
+After=network.target bitcoind.service
[Service]
EnvironmentFile=/etc/electrumx/electrumx.conf