summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD38
2 files changed, 27 insertions, 26 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 14ab2a5d2e77..bb1dc819b27b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,17 @@
+# Generated by mksrcinfo v8
+# Sat Mar 10 18:02:50 UTC 2018
pkgbase = elementary-xfce-icons
- pkgdesc = Elementary icons forked, extended and maintained for Xfce.
- pkgver = 0.9
+ pkgdesc = Elementary icon theme with improved XFCE support
+ pkgver = 0.10
pkgrel = 1
url = https://github.com/shimmerproject/elementary-xfce
arch = any
license = GPL2
- depends = gnome-icon-theme
- optdepends = xfce-theme-albatross: matching Shimmer Project Xfce theme
- optdepends = xfce-theme-bluebird: matching Shimmer Project Xfce theme
- optdepends = xfce-theme-greybird: matching Shimmer Project Xfce theme
+ depends = adwaita-icon-theme
conflicts = elementary-xfce-icons-git
options = !strip
- source = elementary-xfce-icons-0.9.tar.gz::https://github.com/shimmerproject/elementary-xfce/archive/v0.9.tar.gz
- sha256sums = e212da6dc484ac26ec1ecb87f1f8351864f7c94030b8d386844f3de24f99c906
+ source = https://github.com/shimmerproject/elementary-xfce/archive/elementary-xfce-0.10.tar.gz
+ sha256sums = 0526480846cfa20d2232e0ba2e4f2b5a68a4a5dc9f5691ab2ca623a2615d937b
pkgname = elementary-xfce-icons
diff --git a/PKGBUILD b/PKGBUILD
index 51369e66a827..8435f4575e87 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,30 +1,32 @@
-# Maintainer: mortzprk <mortz.prk@gmail.com>
+# Maintainer: Raphael Scholer <rascholer@gmail.com>
+# Contributor: mortzprk <mortz.prk@gmail.com>
# Contributor: Hugo Osvaldo Barrera <hugo@barrera.io>
# Contributor: Limao Luo <luolimao+AUR@gmail.com>
# Contributor: flan_suse <windows2linux@zoho.com>
# Contributor: auscompgeek <auscompgeek@zoho.com>
-pkgname=elementary-xfce-icons
-pkgver=0.9
+_pkgname="elementary-xfce"
+pkgname="${_pkgname}-icons"
+pkgver=0.10
pkgrel=1
-pkgdesc='Elementary icons forked, extended and maintained for Xfce.'
-arch=(any)
-url=https://github.com/shimmerproject/elementary-xfce
-license=(GPL2)
-depends=(gnome-icon-theme)
+pkgdesc='Elementary icon theme with improved XFCE support'
+arch=('any')
+url="https://github.com/shimmerproject/${_pkgname}"
+license=('GPL2')
+depends=('adwaita-icon-theme')
+conflicts=("${pkgname}-git")
options=(!strip)
-conflicts=($pkgname-git)
-optdepends=('xfce-theme-albatross: matching Shimmer Project Xfce theme'
- 'xfce-theme-bluebird: matching Shimmer Project Xfce theme'
- 'xfce-theme-greybird: matching Shimmer Project Xfce theme')
-source=($pkgname-$pkgver.tar.gz::https://github.com/shimmerproject/${pkgname%-*}/archive/v$pkgver.tar.gz)
-sha256sums=('e212da6dc484ac26ec1ecb87f1f8351864f7c94030b8d386844f3de24f99c906')
+source=("${url}/archive/${_pkgname}-${pkgver}.tar.gz")
+sha256sums=('0526480846cfa20d2232e0ba2e4f2b5a68a4a5dc9f5691ab2ca623a2615d937b')
package() {
- cd ${pkgname%-*}-$pkgver
+ cd "${_pkgname}-${_pkgname}-${pkgver}"
- install -d "$pkgdir/usr/share/icons"
- cp -r ${pkgname%-*}{,-dark,-darker} "$pkgdir/usr/share/icons"
+ install -m 755 -d "${pkgdir}/usr/share/icons"
+ cp -r ${_pkgname}{,-dark{,er,est}} "${pkgdir}/usr/share/icons"
- install -Dm644 README "$pkgdir"/usr/share/doc/$pkgname/README
+ # Remove unneeded files
+ cd "${pkgdir}/usr/share/icons"
+ rm ${_pkgname}{,-dark{,er,est}}/{AUTHORS,CONTRIBUTORS,LICENSE}
}
+# vim:set ts=2 sw=2 et: