summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD11
2 files changed, 10 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7b52837e5957..e8a23daf9d26 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,14 @@
pkgbase = elfx86exts
pkgdesc = Decode ELF and MachO binaries and print out which instruction set extensions they use
- pkgver = 0.3.0
+ pkgver = 0.4.0
pkgrel = 1
url = https://github.com/pkgw/elfx86exts
arch = x86_64
license = MIT
makedepends = cargo
- source = elfx86exts.tar.gz::https://github.com/pkgw/elfx86exts/archive/v0.3.0.tar.gz
- sha512sums = 5304e83b4496ac0c2fb4c8dd35e346da814d494aefbbf516dee50c61cbc5477dabfd1c0da09de4e6a513b3ed5861e389a00a984fcbc46d856a69282010fc1607
+ depends = gcc-libs
+ source = elfx86exts-0.4.0.tar.gz::https://github.com/pkgw/elfx86exts/archive/v0.4.0.tar.gz
+ sha512sums = 9af20db584cdf14b3b7072e030a6619d10a289e7fc20534fad30ca11a521ea5e69013455e413e847d2023595da12b9ef3523546fa7a20c9d3f402797a65d02e6
pkgname = elfx86exts
diff --git a/PKGBUILD b/PKGBUILD
index d56cc39d3d0c..da51dc16fb65 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,15 @@
# Maintainer: Sven-Hendrik Haase <svenstaro@gmail.com>
pkgname=elfx86exts
-pkgver=0.3.0
+pkgver=0.4.0
pkgrel=1
pkgdesc="Decode ELF and MachO binaries and print out which instruction set extensions they use"
arch=('x86_64')
url="https://github.com/pkgw/elfx86exts"
license=(MIT)
-makedepends=(cargo)
-source=("$pkgname.tar.gz"::https://github.com/pkgw/elfx86exts/archive/v${pkgver}.tar.gz)
-sha512sums=('5304e83b4496ac0c2fb4c8dd35e346da814d494aefbbf516dee50c61cbc5477dabfd1c0da09de4e6a513b3ed5861e389a00a984fcbc46d856a69282010fc1607')
+depends=('gcc-libs')
+makedepends=('cargo')
+source=("$pkgname-$pkgver.tar.gz"::https://github.com/pkgw/elfx86exts/archive/v${pkgver}.tar.gz)
+sha512sums=('9af20db584cdf14b3b7072e030a6619d10a289e7fc20534fad30ca11a521ea5e69013455e413e847d2023595da12b9ef3523546fa7a20c9d3f402797a65d02e6')
build() {
cd "$srcdir/$pkgname-$pkgver"
@@ -17,7 +18,7 @@ build() {
check() {
cd "$srcdir/$pkgname-$pkgver"
- cargo test --release
+ cargo test --release --locked
}
package() {