summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD28
2 files changed, 42 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..47fe4dc194e0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = elixir-build
+ pkgdesc = Compile and install different versions of Elixir
+ pkgver = 20141001
+ pkgrel = 1
+ url = https://github.com/mururu/elixir-build
+ arch = any
+ license = MIT
+ depends = erlang
+ optdepends = git: install Elixir from git
+ source = elixir-build-20141001.tar.gz::https://codeload.github.com/mururu/elixir-build/tar.gz/v20141001
+ sha256sums = 825637780a580b7ebe8c5265a43d37ceff9f3876e771aa2f824079e504ad7347
+
+pkgname = elixir-build
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7a2e418a442c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Andy Weidenbaum <archbaum@gmail.com>
+# Contributor: Vincent Demeester <vincent@sbr.io>
+# Contributer: Alex Ogier <alex.ogier@gmail.com>
+
+pkgname=elixir-build
+pkgver=20141001
+pkgrel=1
+pkgdesc="Compile and install different versions of Elixir"
+arch=('any')
+depends=('erlang')
+optdepends=('git: install Elixir from git')
+url="https://github.com/mururu/elixir-build"
+license=('MIT')
+source=($pkgname-$pkgver.tar.gz::https://codeload.github.com/mururu/$pkgname/tar.gz/v$pkgver)
+sha256sums=('825637780a580b7ebe8c5265a43d37ceff9f3876e771aa2f824079e504ad7347')
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ msg 'Installing license...'
+ install -Dm 644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+
+ msg 'Installing documentation...'
+ install -Dm 644 README.md "$pkgdir/usr/share/doc/$pkgname/README.md"
+
+ msg 'Installing...'
+ PREFIX="$pkgdir/usr" ./install.sh
+}