summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO23
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD36
3 files changed, 63 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..572bc779c356
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = elm-format-bin
+ pkgdesc = Format Elm source code according to a standard set of rules based on the official Elm Style Guide.
+ pkgver = 0.8.0
+ pkgrel = 1
+ url = https://github.com/avh4/elm-format
+ arch = i686
+ arch = x86_64
+ license = BSD
+ provides = elm-format
+ conflicts = elm-format-0.16-bin
+ conflicts = elm-format-0.17-bin
+ conflicts = elm-format-0.18-bin
+ conflicts = elm-format-0.18-exp-bin
+ source = https://github.com/avh4/elm-format/releases/download/0.8.0/elm-format-0.19-0.8.0-linux-x64.tgz
+ source = https://github.com/avh4/elm-format/releases/download/0.8.0/elm-format-0.19-0.8.0-linux-x64.tgz.asc
+ source = LICENSE-0.8.0::https://raw.githubusercontent.com/avh4/elm-format/0.8.0/LICENSE
+ validpgpkeys = C3B74EE9EBC8412DFEE1FECE11357FB6FDD7BEC0
+ md5sums = ecef0d7d0d66c7b35f9dd1c1ef5f9a52
+ md5sums = SKIP
+ md5sums = e3bb965f28c7631a1bac6d8611a1db7d
+
+pkgname = elm-format-bin
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..018a3de08144
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!PKGBUILD
+!.SRCINFO
+!.gitignore
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..930f5ec01e1f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Jonas Schürmann <jonasschuermann@aol.de>
+# Contributor: Matt Bray <mattjbray@gmail.com>
+_elm_version=0.19
+pkgname=elm-format-bin
+pkgver=0.8.0
+pkgrel=1
+epoch=
+pkgdesc="Format Elm source code according to a standard set of rules based on the official Elm Style Guide."
+arch=('i686' 'x86_64')
+url="https://github.com/avh4/elm-format"
+license=('BSD')
+groups=()
+depends=()
+makedepends=()
+checkdepends=()
+optdepends=()
+provides=(elm-format)
+conflicts=(elm-format-0.16-bin elm-format-0.17-bin elm-format-0.18-bin elm-format-0.18-exp-bin)
+replaces=()
+backup=()
+options=()
+install=
+changelog=
+source=("https://github.com/avh4/elm-format/releases/download/${pkgver}/elm-format-${_elm_version}-${pkgver}-linux-x64.tgz"
+ "https://github.com/avh4/elm-format/releases/download/${pkgver}/elm-format-${_elm_version}-${pkgver}-linux-x64.tgz.asc"
+ "LICENSE-${pkgver}::https://raw.githubusercontent.com/avh4/elm-format/${pkgver}/LICENSE")
+noextract=()
+md5sums=('ecef0d7d0d66c7b35f9dd1c1ef5f9a52'
+ 'SKIP'
+ 'e3bb965f28c7631a1bac6d8611a1db7d')
+validpgpkeys=('C3B74EE9EBC8412DFEE1FECE11357FB6FDD7BEC0')
+
+package() {
+ install -Dm755 "elm-format" "$pkgdir/usr/bin/elm-format"
+ install -Dm644 "LICENSE-${pkgver}" "${pkgdir}/usr/share/licenses/elm-format/LICENSE"
+}