summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD29
-rw-r--r--stack.yaml6
3 files changed, 11 insertions, 42 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 669decea64b..4f69d8fb073 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Wed Jul 11 19:19:46 UTC 2018
+# Tue Aug 21 18:51:48 UTC 2018
pkgbase = elm-platform
pkgdesc = Bundle of all core development tools for the Elm language.
- pkgver = 0.18.0
- pkgrel = 4
+ pkgver = 0.19.0
+ pkgrel = 1
url = http://elm-lang.org
arch = i686
arch = x86_64
@@ -15,17 +15,9 @@ pkgbase = elm-platform
optdepends = nodejs: for elm-repl
conflicts = nodejs-elm
conflicts = elm-platform-bin
- source = elm-compiler-0.18.0.zip::https://github.com/elm-lang/elm-compiler/archive/0.18.0.zip
- source = elm-package-0.18.0.zip::https://github.com/elm-lang/elm-package/archive/0.18.0.zip
- source = elm-make-0.18.0.zip::https://github.com/elm-lang/elm-make/archive/0.18.0.zip
- source = elm-reactor-0.18.0.zip::https://github.com/elm-lang/elm-reactor/archive/0.18.0.zip
- source = elm-repl-0.18.0.zip::https://github.com/elm-lang/elm-repl/archive/0.18.0.zip
+ source = elm-compiler-0.19.0.zip::https://github.com/elm/compiler/archive/0.19.0.zip
source = stack.yaml
- sha256sums = 911109bbedf13c5a5c154ff8b60087b43cfd8be5e165df09b4e8f532a9f22fcd
- sha256sums = a93a2777ee4488510c6e5f82fc7bd7299cbeed7e04004e833d5a8d6f43db44c8
- sha256sums = dcd254ba3c30848bc3527fcab197f8608bc913ae0bee17f67cf97ebf7977dfa6
- sha256sums = 6c5525b2dd35ab6ccf6c5f7e6568bd0164711b8932e80f0caa4a8b9358509902
- sha256sums = 8eba195029a3824fdf690b634f70e925d167f6b3bb7e632dfb1f90900244c87b
+ sha256sums = e6756bc7a8fb63120b0bb187f1d9c9dcc927ad68672f2ae0ae2ed2cb2c3cc278
sha256sums = SKIP
pkgname = elm-platform
diff --git a/PKGBUILD b/PKGBUILD
index 24ccf844503..8209388875f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Lukas Werling <lukas.werling@gmail.com>
pkgname=elm-platform
-pkgver=0.18.0
-pkgrel=4
+pkgver=0.19.0
+pkgrel=1
pkgdesc="Bundle of all core development tools for the Elm language."
arch=('i686' 'x86_64')
url="http://elm-lang.org"
@@ -11,28 +11,16 @@ optdepends=('nodejs: for elm-repl')
makedepends=('stack-static' 'patchelf')
conflicts=('nodejs-elm' 'elm-platform-bin')
source=(
- elm-compiler-${pkgver}.zip::https://github.com/elm-lang/elm-compiler/archive/${pkgver}.zip
- elm-package-${pkgver}.zip::https://github.com/elm-lang/elm-package/archive/${pkgver}.zip
- elm-make-${pkgver}.zip::https://github.com/elm-lang/elm-make/archive/${pkgver}.zip
- elm-reactor-${pkgver}.zip::https://github.com/elm-lang/elm-reactor/archive/${pkgver}.zip
- elm-repl-${pkgver}.zip::https://github.com/elm-lang/elm-repl/archive/${pkgver}.zip
+ elm-compiler-${pkgver}.zip::https://github.com/elm/compiler/archive/${pkgver}.zip
stack.yaml
)
-sha256sums=('911109bbedf13c5a5c154ff8b60087b43cfd8be5e165df09b4e8f532a9f22fcd'
- 'a93a2777ee4488510c6e5f82fc7bd7299cbeed7e04004e833d5a8d6f43db44c8'
- 'dcd254ba3c30848bc3527fcab197f8608bc913ae0bee17f67cf97ebf7977dfa6'
- '6c5525b2dd35ab6ccf6c5f7e6568bd0164711b8932e80f0caa4a8b9358509902'
- '8eba195029a3824fdf690b634f70e925d167f6b3bb7e632dfb1f90900244c87b'
+sha256sums=('e6756bc7a8fb63120b0bb187f1d9c9dcc927ad68672f2ae0ae2ed2cb2c3cc278'
'SKIP')
prepare() {
cd "$srcdir"
ln -sf compiler-${pkgver} elm-compiler
- ln -sf elm-package-${pkgver} elm-package
- ln -sf elm-make-${pkgver} elm-make
- ln -sf elm-reactor-${pkgver} elm-reactor
- ln -sf elm-repl-${pkgver} elm-repl
}
build() {
@@ -43,9 +31,7 @@ build() {
stack build --stack-root "$PWD/.stack"
binpath="$(stack path --local-install-root)/bin"
- for bin in elm elm-make elm-package elm-reactor elm-repl; do
- patchelf --shrink-rpath "$binpath/$bin"
- done
+ patchelf --shrink-rpath "$binpath/elm"
}
package() {
@@ -53,11 +39,6 @@ package() {
binpath="$(stack path --local-install-root)/bin"
install -Dm755 "$binpath/elm" "$pkgdir/usr/bin/elm"
- install -Dm755 "$binpath/elm-make" "$pkgdir/usr/bin/elm-make"
- install -Dm755 "$binpath/elm-package" "$pkgdir/usr/bin/elm-package"
- install -Dm755 "$binpath/elm-reactor" "$pkgdir/usr/bin/elm-reactor"
- install -Dm755 "$binpath/elm-repl" "$pkgdir/usr/bin/elm-repl"
-
install -Dm644 "elm-compiler/LICENSE" "$pkgdir/usr/share/licenses/elm-platform/LICENSE"
}
diff --git a/stack.yaml b/stack.yaml
index 7437a28547c..28ca48a5387 100644
--- a/stack.yaml
+++ b/stack.yaml
@@ -1,8 +1,4 @@
-resolver: lts-6.35
+resolver: lts-11.22
allow-newer: true
packages:
- elm-compiler
- - elm-make
- - elm-package
- - elm-reactor
- - elm-repl