summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD19
-rw-r--r--tools.patch28
3 files changed, 46 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2b0702d9257e..6b2e49774ab1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,7 @@
-# Generated by mksrcinfo v8
-# Tue Jan 17 16:06:40 UTC 2017
pkgbase = eltclsh
- pkgdesc = eltclsh (editline tcl shell) is an interactive shell for the TCL programming language
+ pkgdesc = interactive shell for the TCL programming language
pkgver = 1.16
- pkgrel = 1
+ pkgrel = 2
url = http://homepages.laas.fr/mallet/soft/shell/eltclsh
arch = i686
arch = x86_64
@@ -14,7 +12,9 @@ pkgbase = eltclsh
depends = tcl
depends = tk
depends = libedit
+ source = tools.patch
source = http://distfiles.openrobots.org/eltclsh/eltclsh-1.16.tar.gz
+ md5sums = af3e1e0eb06d1cebed7d4c1bdae5ff29
md5sums = a13130374265b871ff17fdec357aee60
pkgname = eltclsh
diff --git a/PKGBUILD b/PKGBUILD
index 8410901e12c5..cfe19164637a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,9 @@
-# Maintainer: tequa
+# Maintainer: tequa
pkgname=eltclsh
pkgver=1.16
-pkgrel=1
+pkgrel=2
epoch=
-pkgdesc="eltclsh (editline tcl shell) is an interactive shell for the TCL programming language"
+pkgdesc="interactive shell for the TCL programming language"
arch=('i686' 'x86_64' 'armv7h')
url="http://homepages.laas.fr/mallet/soft/shell/eltclsh"
license=('BSD')
@@ -19,11 +19,20 @@ backup=()
options=()
install=
changelog=
-source=("http://distfiles.openrobots.org/eltclsh/$pkgname-$pkgver.tar.gz")
+source=(
+ "tools.patch"
+ "http://distfiles.openrobots.org/eltclsh/$pkgname-$pkgver.tar.gz"
+)
noextract=()
-md5sums=('a13130374265b871ff17fdec357aee60')
+md5sums=('af3e1e0eb06d1cebed7d4c1bdae5ff29'
+ 'a13130374265b871ff17fdec357aee60')
validpgpkeys=()
+prepare() {
+ cd "$pkgname-$pkgver"
+ patch -Np1 -i "${srcdir}/tools.patch"
+}
+
build() {
cd "$pkgname-$pkgver"
./configure --prefix=/usr
diff --git a/tools.patch b/tools.patch
new file mode 100644
index 000000000000..9325010e00ac
--- /dev/null
+++ b/tools.patch
@@ -0,0 +1,28 @@
+--- a/tcl/tools.tcl 2012-11-22 22:34:00.000000000 +0100
++++ b/tcl/tools.tcl 2018-08-03 12:41:39.614684540 +0200
+@@ -36,6 +36,7 @@
+ return $h
+ }
+
++if {[llength [info commands lreverse]] == 0} {
+ # return the same list in reverse order
+ proc lreverse { list } {
+
+@@ -45,7 +46,9 @@
+ }
+ return $reverse
+ }
++}
+
++if {[llength [info commands lmap]] == 0} {
+ # aply command map on each element of list, returning the a new list
+ proc lmap { list map } {
+ set mapped {}
+@@ -54,6 +57,7 @@
+ }
+ return $mapped
+ }
++}
+
+ # print line wrapped to specified width
+ proc wrappedputs { line width } {