summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO18
-rw-r--r--2.6.35.patch15
-rw-r--r--PKGBUILD27
3 files changed, 60 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..32e0324a1cb5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = em8300-utils
+ pkgdesc = DXR3 and Hollywood+ driver
+ pkgver = 0.18.0
+ pkgrel = 2
+ url = http://dxr3.sourceforge.net/
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ makedepends = gtk2
+ optdepends = gtk2: to use dxr3view, dhc or autocal
+ optdepends = perl: to use em8300 scripts
+ source = http://downloads.sourceforge.net/project/dxr3/em8300/0.18.0/em8300-0.18.0.tar.gz
+ source = 2.6.35.patch
+ md5sums = 2ef10f5159508a31a877e7e6d18c6896
+ md5sums = 922a6f5641a805ca05c2b712caeed9f8
+
+pkgname = em8300-utils
+
diff --git a/2.6.35.patch b/2.6.35.patch
new file mode 100644
index 000000000000..1cc93daa495e
--- /dev/null
+++ b/2.6.35.patch
@@ -0,0 +1,15 @@
+*** ../include/linux/em8300.h.old 2010-08-04 00:33:05.352620013 +0300
+--- ../include/linux/em8300.h 2010-08-04 00:33:19.900620013 +0300
+***************
+*** 234,239 ****
+--- 234,243 ----
+ #include <linux/wait.h> /* wait_queue_head_t */
+ #include <linux/list.h> /* struct list_head */
+
++ #if LINUX_VERSION_CODE >= KERNEL_VERSION(2,6,34)
++ #include <linux/semaphore.h> /* struct semaphore */
++ #endif
++
+ #if defined(CONFIG_SND) || defined(CONFIG_SND_MODULE)
+ #if LINUX_VERSION_CODE >= KERNEL_VERSION(2,6,16)
+ #define snd_card_t struct snd_card
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5ad224a07e75
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# $Id: PKGBUILD 6743 2009-12-21 12:17:19Z ibiru $
+# Contributor: Jaroslaw Swierczynski <swiergot@aur.archlinux.org>
+
+pkgname=em8300-utils
+pkgver=0.18.0
+pkgrel=2
+arch=('i686' 'x86_64')
+pkgdesc="DXR3 and Hollywood+ driver"
+url="http://dxr3.sourceforge.net/"
+license=('GPL2')
+makedepends=('gtk2')
+optdepends=('gtk2: to use dxr3view, dhc or autocal'
+ 'perl: to use em8300 scripts')
+source=(http://downloads.sourceforge.net/project/dxr3/em8300/${pkgver}/em8300-${pkgver}.tar.gz
+2.6.35.patch)
+md5sums=('2ef10f5159508a31a877e7e6d18c6896'
+ '922a6f5641a805ca05c2b712caeed9f8')
+
+build() {
+ cd "${srcdir}/em8300-${pkgver}"
+ patch -p1 < $srcdir/2.6.35.patch
+ ./configure --prefix=/usr
+ make || return 1
+ make DESTDIR="${pkgdir}" install || return 1
+
+ install -m 644 -D modules/em8300-udev.rules "${pkgdir}/lib/udev/rules.d/em8300.rules" || return 1
+}