summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD32
2 files changed, 50 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..20b4a3060563
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = emacs-ag-git
+ pkgdesc = An Emacs frontend to The Silver Searcher (binary name ag)
+ pkgver = 0.47r49.g77b4f50
+ pkgrel = 1
+ url = https://github.com/Wilfred/ag.el
+ arch = any
+ license = GPL3
+ makedepends = git
+ depends = emacs
+ depends = emacs-dash
+ depends = emacs-s
+ provides = emacs-ag
+ conflicts = emacs-ag
+ source = git+https://github.com/Wilfred/ag.el.git
+ md5sums = SKIP
+
+pkgname = emacs-ag-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7670d0b41597
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Contributor: Alex Whitt <alex.joseph.whitt@gmail.com>
+# Maintainer: Stefan Husmann <stefan-husmann@t-online.de>
+
+pkgname=emacs-ag-git
+pkgver=0.47r49.g77b4f50
+pkgrel=1
+pkgdesc="An Emacs frontend to The Silver Searcher (binary name ag)"
+arch=('any')
+url="https://github.com/Wilfred/ag.el"
+license=('GPL3')
+depends=('emacs' 'emacs-dash' 'emacs-s')
+makedepends=('git')
+provides=('emacs-ag')
+conflicts=('emacs-ag')
+source=("git+${url}.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd ag.el
+ git describe --tags | sed 's+-+r+' | tr - .
+}
+
+build() {
+ cd ag.el
+ emacs -q --no-splash -batch -L . -f batch-byte-compile *.el
+}
+
+package() {
+ cd ag.el
+ mkdir -p "$pkgdir"/usr/share/emacs/site-lisp
+ install -m644 *.el{c,} "$pkgdir"/usr/share/emacs/site-lisp
+}