summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD29
2 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..11e72196de47
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+# Generated by mksrcinfo v8
+# Thu Aug 22 16:02:40 UTC 2019
+pkgbase = emacs-annot-git
+ pkgdesc = A global annotator/highlighter for GNU Emacs
+ pkgver = r62.964e6d0
+ pkgrel = 1
+ url = https://github.com/ghoshi/annot
+ arch = any
+ license = unknown
+ makedepends = git
+ depends = emacs
+ provides = emacs-annot
+ source = emacs-annot::git+https://github.com/ghoshi/annot.git
+ md5sums = SKIP
+
+pkgname = emacs-annot-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d4817aede62b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# $Id: pkgbuild-mode.el,v 1.23 2007/10/20 16:02:14 juergen Exp $
+# Maintainer: L.G. Sarmiento (Pico) <Luis.Sarmiento-ala-nuclear.lu.se>
+pkgname=emacs-annot-git
+_pkgname=emacs-annot
+pkgver=r62.964e6d0
+pkgrel=1
+pkgdesc="A global annotator/highlighter for GNU Emacs"
+url="https://github.com/ghoshi/annot"
+arch=('any')
+license=('unknown')
+depends=('emacs')
+makedepends=('git')
+provides=($_pkgname)
+
+source=($_pkgname::git+https://github.com/ghoshi/annot.git)
+md5sums=('SKIP')
+
+pkgver() {
+ cd ${srcdir}/$_pkgname
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package(){
+ cd ${srcdir}/${_pkgname}/src || return 1
+
+ mkdir -p ${pkgdir}/usr/share/emacs/site-lisp || return 1
+
+ install -Dm644 annot.el ${pkgdir}/usr/share/emacs/site-lisp/ || return 1
+}